coolant temp gauge problem [Archive] - GrandAmGT.com Forum

PDA

View Full Version : coolant temp gauge problem


xtremecold101
01-07-2006, 12:49 AM
I really need someones help here, just today my coolant temp gauge started going crazy moving back and forth to the opposite sides of the gauge. I already changed the temperature switch, in the front of the engine right under the TB. Still no change. The car seems to act sort of strange when driving as well, sorta lags and whatnot. Please, help me i dont know what else to start with. Did anyone else ever have this problem. O and by the way the car isnt too too old, its a 2002.

RedGrandTour
01-07-2006, 09:08 AM
Are the fans running when it does that?I had the same problem on my 01. The temp guage would go from 0 to normal all the time and mostly it wouldn't read at all. The fans stayed on all the time and the car drove sluggish. I waited to long to fix it and the heat would not get hot in the cold winter.

Thermostat was replaced and it drives like new. Warms up very quickly. If your thermostat is getting stuck it won't throw a code. If the sensor was bad I was told that it would send a code or cause a SES light.

xtremecold101
01-07-2006, 01:45 PM
Actually i believe the fans arent always on but they come on when there supposed to, or so i think. With the gauge bouncing around llike crazy its hard to tell. I mean it constantly sweeps back and forth for a while then it goes back to normal etc, its very inconsistant. Idk if its just me being paranoid now but like i said the car seems to feel differently, when it shifts and the throttle etc.. And i just got a 180 degree thermostat put on about a month ago so i dont think it could be that. O and hmm yes i do get heat. I just dont know, i hope its just the temp sender but, i was just asking for other opinions. I am thinking about taking it to the dealer on monday. Any more ideas?

UPDATE: I took my car to the dealer and they told me that I have an intake leak and a possible head gasket leak. Hmm so thats what it was.