Car died and will not start [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Car died and will not start


AznGA
01-16-2006, 07:14 PM
I was driving on the road and all of a sudden it started running sluggish. It did not want to accelerate. I pulled into a parking lot and it finally died. Tried starting it, but it only cranked and didn't start. After some tries, it stopped cranking and all I heard was a click from the starter.

Tried starting with my friend's car. We connected the jumper cable, waited 5 minutes and tried starting. It cranked again, but still no start. While it was cranking, he disconnected the jumper cable and it stopped cranking.

GrahamKracka
01-16-2006, 07:22 PM
fuel pump

GrandAmGT1996
01-16-2006, 10:39 PM
Possibly an alternator? Fuel pump sounds more like it though

GrahamKracka
01-17-2006, 08:38 PM
i had the exact same problems with the exact same symptoms....fuel pump

AznGA
01-17-2006, 11:40 PM
I got the battery tested today and it's pretty low. Held the key at "start" position and all it does is multiple clicks. Getting the alternator tested tomorrow to narrow things down.

Ajaxus
01-18-2006, 12:02 AM
whats the condition of the battery terminals? corrosion?

AznGA
01-23-2006, 09:04 PM
Got the battery and alternator tested. I needed a new battery. It was so low that they couldn't even recharge it. I never had trouble starting my car before it died on the road. I have no clue how a battery can go bad all at once just like that. Maybe because it's from AC Delco.

DrFabulous
01-23-2006, 09:10 PM
^^ My batt just died like that a couple weeks ago, too. It sucked. Out of nowhere, dead.

99GAGTX
01-23-2006, 09:14 PM
AC Delco batteries aren't all bad. When I sold my 1991 Z24 in the summer of 1999, it still had the factory original battery in it. And it also had all the optional equipment. I'm still running the GA with the original battery, but I did have to have the alternator changed in 2001.