How long did your stock battery last you? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : How long did your stock battery last you?


coupe
02-21-2006, 11:33 AM
Mine lasted me 7 years and 70K miles and its still goin strong.
I just went out to check on my car (its in storage) and i figured hell i will start it up. I didnt think the battery would be good by now given its age and how long my car has been sitting and hasnt been started. I figured for sure the battery was dead but nope fired right up like a champ.
My battery outlasted my alternator lol My alt died at about 67K miles.
I did order an optima yellow top D34/78 just in case, i cant imagine my stocker actually lasting any longer.

jordanGT
02-21-2006, 11:43 AM
Mine went almost 4 years, 60,000 miles or so.

sc02grandam
02-21-2006, 11:57 AM
3yrs.. 28000 mi

coupe
02-21-2006, 12:28 PM
3yrs.. 28000 mi

How was that possible? Big system right? lol Drain it to many times maybe?

excitement
02-21-2006, 12:50 PM
Still on stock alt/batt at 5 years and 124K miles. knocking on wood...

2002GT
02-21-2006, 01:39 PM
3.5 years 50k

dsk727
02-21-2006, 01:41 PM
4 years, 3 months and 85K miles still going *knock on wood*

RAZE
02-21-2006, 02:00 PM
5 years 62,000 miles and still running strong when i traded it in.

AznGA
02-21-2006, 02:05 PM
My factory battery lasted about 4 years and 85k miles before it recently completely died on the road all of a sudden. I put a new alternator in today because the bearing was gone.

DrFabulous
02-21-2006, 03:04 PM
5 years, 65k miles.... 1.5 years, 20k miles with a system.

cavingman
02-21-2006, 03:09 PM
as long as it took for pfyc to ship my redtop lol

Kdawg207
02-21-2006, 03:10 PM
as long as it took for pfyc to ship my redtop lol


same here


my stock 03 battery died at 18000 miles

redtop wasnt much better to be honest

i ended up with an Interstate

videoman
02-21-2006, 03:39 PM
Mine was ok at 4 yrs 48000kms, but it was still ok when I got rid of it for a redtop. I was moving the battery to the trunk in my car and figured a dry cell higher output battery would be best for this mod. When I sold the batt it was about 395CCA and the new redtop was about 780CCA.

tenspeed
02-21-2006, 04:54 PM
4 years and 60,000 miles so far.

In the Navy, we were taught that lead acid batteries lasted for three to five years or 300 full cycles. A cycle is a full discharge and recharge. Each time you start your car, you use part of one discharge.

Coop
02-21-2006, 04:56 PM
Still going, 5 years, 40k miles

Coop
02-21-2006, 04:57 PM
*edit* grrr, double post

Mike Jung
02-21-2006, 05:35 PM
3-years.

Then on to an Optima RedTop battery.

nascarnate326
02-21-2006, 05:48 PM
Still on my stock battery with 128k. I think its starting to die. Ive herd good things about those red toped ones.
OT Do comopasaters help keep the battery longer if you have a large system?

traingeek087
02-21-2006, 06:07 PM
7 years and 91,000 as of today

SkiZZor
02-21-2006, 06:16 PM
6 years, 59,600 miles. It just died out in January, and got a BOSCH replacement.

digitalballz
02-21-2006, 06:17 PM
3.5 years and about 40k

AleroME
02-21-2006, 06:34 PM
same here


my stock 03 battery died at 18000 miles

redtop wasnt much better to be honest

i ended up with an Interstate

LOL.. Interstate makes the optima's . You prolly just got a bad one. It happens. Nothing is perfect.

But mine lasted 2 yrs w/ 30k miles back in 2002 i swapped it out. The good ole GM acid-leaky positive terminal.

digitalballz
02-21-2006, 07:17 PM
I got my interstate for free.

mightypan42
02-21-2006, 08:04 PM
Dunno if it was the stock battery or not, but when I got my GA it had 60k on it and lasted until my alternator went out and I replaced both.

sc02grandam
02-21-2006, 09:16 PM
How was that possible? Big system right? lol Drain it to many times maybe?

lol no clue.. i myself only drained it once when i was installing the remote starter.. and on that battery i had a system for maybe only 4-5 months then i removed it

juanvan
02-22-2006, 06:47 AM
4 years 60K not too bad..

Slim
02-22-2006, 06:54 AM
Mine was still going strong after 4 years and 70,409 KMs when I turned the car back in.

99GAGTX
02-24-2006, 07:43 PM
Still on the factory original battery. But in the past week, we've had a couple really cold days. On those two days, I noticed that when I started the car for the first time that day, the first revolution of the starter was kinda slow. So I'm expecting it to go soon.

When I sold my 1991 Z24 in the fall of 1999, it still had the original battery. I've had good luck with Delco batteries so far. The one in my GA survived a failed alternator 3 or 4 years ago.

bigtard
02-25-2006, 03:09 AM
When I bought my 99 in 2005, it had the original. However, 1 month of Arizona heat toasted it. Word on the street down here is that batteries don't last long in the desert.

stanjk3
02-25-2006, 11:32 PM
Finally changed mine last summer, 5 years ~74K miles.
Car would still crank, but it took a couple cranks. Also my radio kept losing its memory.

GrahamKracka
02-26-2006, 12:10 AM
well its not a GA....but my bikes battery is drained haha

rocketfast123
02-27-2006, 01:13 AM
about 3.5years

Y2KGA
02-27-2006, 06:44 PM
Changed mine at 5 years as a precaution. Getting stranded in the middle of winter is not fun.

KeyserSosa2000
03-04-2006, 08:32 AM
Got stranded about 15 minutes from my house yesterday when my battery decided not to work. I'm talking nothing....no interior lights or anything.

The worst part is I called my buddy for a jump but there is something weird about his car, I think it's positively charged, because with the jumper cables on correctly (I tride twice) there was huge sparks and my one cable end started on fire.

I'm a little upset to say the least.

oh, ps - I got my car started and home but I'm very worried about my altenator now.

Ajaxus
03-04-2006, 09:37 AM
a car cant be positively charged as you say, my guess is that one of your terminals is corroded and you had a bad connection or quite possibly his cables are a p.o.s.

actually im gonna put my money on some bad cables

action
03-09-2006, 07:27 AM
3 years....

coupe
03-09-2006, 07:30 AM
I cant believe my battery has lasted 7 years and is still good.
I changed it out with an optima yellow top anyway just to be safe but my stocker is still good.

MetaGTP1
03-09-2006, 09:05 AM
The OEM battery in my GAGT lasted 4 years.

coupe
03-09-2006, 09:09 AM
I think i have set a record lol

Tony
03-11-2006, 11:43 AM
My stock battery lasted 6 years (including 6 Canadian winters; kept garaged for 5 years) and 58,000 km. It had trouble starting as the weather began to get colder just before this winter.

xxbackhillxx
03-11-2006, 01:40 PM
36800. not even three years.

Ajaxus
03-11-2006, 02:11 PM
i think it was about the same for me as tom's was, terminals both corroded off

MMGT1
03-11-2006, 02:25 PM
5 years, just under 100km's.......

Graxall
03-11-2006, 03:08 PM
1.5yr 38k mi