No interior lights. HELP!!! [Archive] - GrandAmGT.com Forum

PDA

View Full Version : No interior lights. HELP!!!


awaadster3
03-09-2006, 10:56 AM
I've seached this thread for a couple days and didn't find an exact answer, but a few leads.

When I was installin my Pioneer D1 one of the wires hit the metal backing in the car causing sparks. Soon after my Speedometer/Tach, HAVC, and Gear indicator don't light up. Everything eles works in the car. \

I checked all my fuses, they all work.

could it be a relay? I read on this forum it could be a relay behind the dash and would need a visit to the dealer?

Kdawg207
03-09-2006, 11:01 AM
did u test all fuses ....or just eyeball em

they happened to me twice...both time it was a fuse

awaadster3
03-09-2006, 12:21 PM
i tested them, and every fuse light up.

which fuse gave u problems? if u remember

Kdawg207
03-09-2006, 12:22 PM
i think it was the instrument cluster - was a while ago - but i do remember thinking how odd that more than just the instrument panel was effected...but it was


it was one of the beefy bastards under the hood fuse box

freakydeaky
03-09-2006, 01:19 PM
it's a 30A maxi-fuse under the hood.. check 'em

awaadster3
03-09-2006, 11:12 PM
it's a 30A maxi-fuse under the hood.. check 'em

check'd em, all good. any other ideas.

AleroME
03-10-2006, 01:17 AM
right side of dash fuse box .. check the fuse called "cruise" or something around that fuse. I remember mine went out before. its a 10amp fuse.

awaadster3
03-13-2006, 09:09 AM
thanks for all the replys.

i just found the fuse. it is the INT LP fuse on the passanger side fuse box. it a 10amp fuse in the upper right hand corner, i believe its the only one up there.

Kdawg207
03-13-2006, 09:29 AM
knew it would be a fuse

congrats for fixin it

brim
03-14-2006, 09:32 AM
no comment


hehe