0% Power Nothing turns ON! [Archive] - GrandAmGT.com Forum

PDA

View Full Version : 0% Power Nothing turns ON!


juanvan
03-13-2006, 08:54 AM
Background:
The car had been actting funny, for a little, where the car would not start and the battery was dead. A simple jump would get it going, and replaced the battery. Shortly after replacing the batter, the car just stopped showing any signs of power even with another battery connected, or jump or anything.
So went threw and checked the fuses. One of the Big fuses under the hood was popped. (Have to find out exactly what one) 60 I belive. And a smaller one.

But my Q: is what would stop everthing. No Dome, no headlights, no dash nothing. Like there is 0% power, no battery attached.

My thoughts:
I was thinking relay, but for so Many items not working all at the same time! all at once.
Next thing, would a Bad PCM Cause this?
Could a Major ground case this?
Or could a power surge have done some major damage to another piece, due to the jumping that took place for about a week to get the battery replaced.
Short of running a lead wire off the batter to every link.

5-lO
03-13-2006, 09:17 AM
What about your battery ground wire? That can cause the battery to die, as well as no grounding for the vehicle so you get an incomplete circuit.

B1ackG7
03-13-2006, 11:43 AM
sounds like a major ground somewhere. check any loose wires you have around the car or trunk.

badboy2451
03-13-2006, 11:58 AM
could have also killed the alternator

juanvan
03-13-2006, 12:56 PM
Well if its not the damdest thing, a piece of a cig pack Foil, got into the bottom of the fuse box!
Well its fixed

Thanks

Edit: Guess my car has now taking up smoking too.. lol

digitalballz
03-13-2006, 05:05 PM
another thing to watch for is change in the cig lighter. Had that happen and it pops fuses and the car runs like crap.