Water pump changed, low coolant light comes on now [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Water pump changed, low coolant light comes on now


coupe
03-31-2006, 12:33 PM
when i give it 75% throttle. I have heat, car isnt runing hot. Think maybe i have an air buble or not enough coolant?

Slim
03-31-2006, 01:03 PM
How full is your coolant bottle?

coupe
03-31-2006, 01:13 PM
When cold it is at the line that says "full cold" (something to that affect) or whatever. I think i might have an air bubble.

Slim
03-31-2006, 01:23 PM
When cold it is at the line that says "full cold" (something to that affect) or whatever. I think i might have an air bubble.

Dunno. I'm not 100% sure where the sending unit for the low coolant light is...

coupe
03-31-2006, 01:28 PM
Its under the coolant resevoir (sp?). At least i think thats what that is lol

digitalballz
03-31-2006, 06:32 PM
Probly a bubble. Try break tourqing it to get it to move. Also wont hurt to add a little more to the resovoir.

coupe
04-01-2006, 08:27 AM
All fixed now, thanks guys!

AaronGTR
04-01-2006, 10:03 AM
The coolant level sensor is in the bottom of the reservoir. Usually our system will work air out on it's own after it runs for a while. Thats what the extra little hoses are for, like the one that runs from the coolant neck across the front of the engine to the reservoir. They let air work it's way from the high points back to the reservoir. The air will all work it's way out eventually, so you just have to keep checking the coolant level. :)

coupe
04-03-2006, 06:09 AM
The coolant level sensor is in the bottom of the reservoir. Usually our system will work air out on it's own after it runs for a while. Thats what the extra little hoses are for, like the one that runs from the coolant neck across the front of the engine to the reservoir. They let air work it's way from the high points back to the reservoir. The air will all work it's way out eventually, so you just have to keep checking the coolant level. :)


That would make sense becuase after about 50 miles of driving the light just stopped coming on and i just had to add a little more coolant.