damn this thing is falling apart!! any ideas whats wrong?? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : damn this thing is falling apart!! any ideas whats wrong??


ninobrn99
04-10-2006, 01:24 PM
Well I know ive got the LIM leak so Im saving to get that fixed. My saches on my driverside window also took a ****. luckily the window didnt break. Well here's a few things ive noticed wrong with the car:
*Car doesnt always wanna start right away. takes a few times to crank it over.
*When Im going to park the car, stop it, hold the brake, pull the ebrake up, then the car jerks foward after i let off the brake. It also surged when im turning into my parking spot. Ill be going really slow, then all of a sudden it jumps foward and i have to be quick on the brake or ill hit the car next to me.
*the car has a huge lack of power. It stalls when you give it gas. Either you wait to build up speed or u punch it and even then it takes forever. If Im crusing on anywhere at any speed, if I tap the gas the RPM's shoot up about 2k then drop down.
*The abs/low trac light comes on when im pulling out of my parking spot and put it in drive.
*Reverse takes a few seconds to engage.
*Door locks engage and disengage on their own when the car is turned on. It does it for a while after driving, then stops on its own.
*Even with the car fully warm, the defrost blows cold air. I have to keep turning it off and on before it begins to blow hot air.
*sunroof only opens about 3"s and sometimes all the way.

Thats a short list of **** wrong with the car. Any and all help is appreciated! Besides running this beeotch into a wall or leaving the keys in it for someone to take that damn thing, I dont know what else to do :(

Kdawg207
04-10-2006, 02:20 PM
sounds like you hit every recall and every bulletin this car ever received. welcome to the lovely ga community.

There are threads all over this place on each and every issue you listed.

Search - you will find a ton

I had 3 of those all in one year lol

coupe
04-10-2006, 02:22 PM
Yeah but at the same time ive only had 1 of those problems......

Exodus
04-10-2006, 02:52 PM
2 for me. LIM leak and engine hesitation. Sometimes acceleration is fine other times sux balls. These cars at times are like chicks w/ PMS

Panacea
04-10-2006, 05:03 PM
Problem: Car doesn't want to start right away.
Solution: Turn the car to the "ON" position for 5 seconds, then turn the key to start it.

Problem: Car takes a few seconds to go into reverse.
Solution: Nothing, that's normal.

Problem: Lack of power.
Solution: Do the necessary maintenance (Spark plugs/wires, fuel filter, air filter, etc. etc.)

ninobrn99
04-12-2006, 05:03 PM
Problem: Car doesn't want to start right away.
Solution: Turn the car to the "ON" position for 5 seconds, then turn the key to start it.

Problem: Car takes a few seconds to go into reverse.
Solution: Nothing, that's normal.

Problem: Lack of power.
Solution: Do the necessary maintenance (Spark plugs/wires, fuel filter, air filter, etc. etc.)
Done the maintenance. New plugs, wires, air and fuel filters. The tranny issues doesnt seem right. It cant be normal. Im gonna get it flushed and see if that helps. I just dont have the time to work on this car and my LS1. I just wanna get it fixed and sold!!! :D Im sure you all feel me ;)