Squeak help [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Squeak help


puckyou
05-19-2006, 11:17 PM
Begin Rant/

So last summer I had squeak with the old belt and replaced it with a gatorback, new tension pulley and idle pulleys, the sqeak went away initally but returned soon after. A couple of months went by and it slowly went away and would return on occassion here and there. Now after installing the SC, I again had to install a new belt and of course the squeak returns, 10x as loud. As the car warms up it tends to go away at idle but roars with any throttle. It sounded like it was coming from the power steering pump so I swap that out today only for the squeak to remain. I have also replaced the alternator a while back when the stock one crapped out.

Does anyone have any ideas??? I am too embarrassed to drive the car as the squeak is louder than the SC whine and exhaust together......

/end rant.

lone_wolf025
05-19-2006, 11:22 PM
Its times like this I wish I had the manual in front of me...

Check any other pulleys to make sure they're tight and not wobbling.
(water pump, a/c, even the harmonic balancer)

What was the condition of the belt that was most recently replaced? I assume that the pulleys are all clean and don't have tracks filled with gunk or dirt.

Any oil or water leaks onto the belt?

-Edit-
Your belt is slipping due to some unknown cause and I'd wager that the additional load created by the s/c is causing it to slip even more, hence more noise now.

puckyou
05-19-2006, 11:27 PM
Pulleys are clean, the gatorback was practically brand new. I think that the tension of a new belt causes something to squeak. I just need to find it, NOW, I AM TIRED OF THIS NOISE!!!

No oil, water, etc....I am going to swap the old alternator in tomorrow for *h*ts and giggles.......

I don't think the belt is slipping.....