Idle RPMs [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Idle RPMs


Rizzo22
05-24-2006, 06:51 PM
This may not be a major problem but kinda bothers me.

When the car is first started after sittin for awhile it idles as 1200rpm for bout 30 secs. than drops to around 600-700 rpm. Not sure what the problem may be or even if there is one. Drop ya ideas, thank ya.

puckyou
05-24-2006, 07:00 PM
Mine did the same, when cold idled around 1200, then as it warmed up, idle dropped to 650-700.

badboy2451
05-24-2006, 09:19 PM
maybe a new pcv valve and some seafoam will help

videoman
05-24-2006, 10:01 PM
Thats perfectly normal, mine idles around 660 RPMs when it warm.

lone_wolf025
05-24-2006, 10:05 PM
Thats perfectly normal, mine idles around 660 RPMs when it warm.

Exactly. The song and dance behind it is that the engine is cold and has to run richer and faster to get into closed loop. Once its in closed loop the R's drop and the mix leans out.

Back in the day of carbs you'd really have to sit and run the thing for a while before it would be warm enough to sustain power under load.

KeyserSosa2000
05-25-2006, 02:49 PM
same. as above. Like 1200-1500 at a cold start, takes a bit to drop down, but if I start it up like 10 minutes after having the oil temperature at 90, it idles just under 1000.

slickjoe
05-30-2006, 01:12 PM
yea my car does the same, and so does my other buddy's GT. I also have a question. Does anyone have a minor issue with their power window panel on the driver's side door making noises while driving??

coupe
05-30-2006, 01:28 PM
Lets clear this up, ALL ENGINES DO THIS, man you guys ever drivin anything else? lol
Jon explained why they do this.