Brake size cause trac/abs system to malfunction? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Brake size cause trac/abs system to malfunction?


MBLAX32
06-10-2006, 06:47 PM
I replaced my stock discs with cross drilled/slotted rotors all around and since then have run into the age-old "trac off" and "abs" lights all the frickin time. After reading the million and one posts referring to a bad hub or speed sensor, I had the hubs/sensors checked out and my mechanic said they were ok. Now I ask, is it possible that if the brakes were not exactly to oem size that it would affect this system? Any thoughts are MUCH appreciated!!

1coop44
06-12-2006, 05:55 AM
The Brake rotors shouldn't effect that at all.

coupe
06-12-2006, 06:25 AM
Its not the rotors.

Go to a different mechanic and get another opinion.

tomh
06-12-2006, 09:59 AM
go to a mechanic with a good scan tool they can tell you which hub it is in like 30 seconds or tell you if it is something else. (Dealers going to charge you atleast $60+ for that) the guy I take mine to charges me nothing.

MBLAX32
06-12-2006, 03:29 PM
Thanks guys, I went to another place and the guy didn't say "hub" but he suggested new bearings.. I'm still gonna stick w/your opinions on the SVS/Trac Off/ABS light theories though and be suggestive of hub replacement... thanks again-

tomh
06-12-2006, 04:47 PM
the bearings/abs sensor are in the "hub" but you need to figure out which one it is.. hence why i suggested someone with a scan tool :)