LIM gasket-rear valve cover PITA [Archive] - Forum


View Full Version : LIM gasket-rear valve cover PITA

08-11-2006, 06:46 PM
How did you guys who had the LIM gasket problem remove the rear valve cover...the one that is near the alternator bracket. IT seems like there is no way in hell i can get those stupid lines out of there. Any tips? I think im making good timing here. I did a total of 4 hrs today and all i need left is the valve cover and off goes the LIM.

08-11-2006, 07:10 PM
You need to move the power steering pump out of the way and remove the alternator. Only way to move the pump is by unbolting it. If I remember correctly, there should be 3 bolts holding it with one located on the bottom of the pump. You will have to feel for it.

08-11-2006, 08:36 PM
i removed both the power steering pump and the alternator, my problem is getting to 1 of the 4 small bolts on the valve covers. The one on the alternator side

08-11-2006, 09:58 PM
Do you have a 1/4" drive rachet? The smaller the better.

08-12-2006, 10:06 AM
yes sir i do but i still cant get in there even with a 1/4 inch drive ratchet...i'll try again today

08-12-2006, 11:24 AM
thank god for swivel sockets!!

08-12-2006, 12:18 PM
actually i had to just take the alternator bracket completely off...much easier ...

02-24-2007, 05:00 PM
[QUOTE=Firebirdnyc;814579]actually i had to just take the alternator bracket completely off...much easier ...[/QUOTE

Is there a hidden bolt on this??? I tried to get it off and removed the three bolts but couldnt see anything else and still it tied on there!!!!