Help an old memeber out...high idling [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Help an old memeber out...high idling


tranceokido
09-09-2006, 09:25 AM
Hey guys its Blake again. A lot of you probably don't remember me because i was regular on this forum for only a short period of time. until I got my GPGTP. Well I am having problems with mom's 99 GAGT. I haven't looked at it yet...just driven it. It is idling really high. Betweek 1.5K and 2Krpm. It does it in all gears...and when your in drive but stopped at a light...it idles so high you must put it nuetral so the car won't take off and to take stress off the tranny. You can feel the TQ managment kicking it as soon as your go from Nuet-drive (you know GM's way to avoid neutral drops). I must ad that this all seems to be an intermitten problem. Somedays it does it and somedays its fine, but it did just start this week. This leads me to think is a sensor of some sort. MAP maybe? (aren't GA MAF based though?) Anways....I was wondering if anyone as experienced similar problems or what not. Please help a fellow Pontiac owner out, i look foward to the responses.

digitalballz
09-09-2006, 10:54 AM
sounded like a vacuum leak till you said it was intermittent???

tranceokido
09-09-2006, 03:19 PM
Well I go to check things out and first thing I check is the air filter. Hmm...the things if f*ing black...totally clogged. So I replaced that when I changed her oil and so far so good...will see if maybe that was the problem and the MAF was getting weird readings. I keep you guys posted...but should you think of other probable causes then give me a shout. If it doesn't work I'll be looking back here for more solutions.

brim
09-12-2006, 08:45 AM
maf won't make it idle high, it would've more than likely been a TPS sensor from what you're saying, but who knows, it's gone right?

AmbrosiaCaress
09-14-2006, 11:07 AM
I had this exact problem... on my 99 GAGT...

It did end up being the TPS sensor.. cost me $135 to replace... but it is all set now... yay...