Radio light quite working [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Radio light quite working


bwwelk
10-05-2006, 08:22 PM
on my 01 ga gt the light in side all sudden quite working ,,,,the radio and cd player still work but you cant tell what station , time or anything ... Any one know what this could be ??????? Thanks

dxtreme_85
10-05-2006, 10:05 PM
Same happened to mine. I just got a new GM radio out of an 05 Grand Am that had the MP3 player built in, cost me 80 bucks and another 30 to have a tech reprogram it

Lab Rat
10-06-2006, 05:15 AM
I pulled the radio out, then found and pulled the bulb out. It's a little like an old time taillight. 1/2 turn and it pulls out. The contacts were dirty. I cleaned them, reinstalled the bulb and it has been working for a couple of years now. But the newer one sounds like a better choice, just more $.

bwwelk
10-06-2006, 01:50 PM
Ok thanks Ill try taking it out and cleaning connections or replacing bulb...

dxtreme_85
10-06-2006, 09:17 PM
The newer GM delco radios that come in the GT models (Premium Sound) aren't like taillight bulbs, they are more like LEDs and take quite a bit of work to get to them, I would know, I took mine apart with the intention of replacing them w/ blue ones and converting the radio to all blue. I am assuming that you are talking about the actual display of the radio (where the station and clock and whatnot are displayed) if so, then there are 3 cylinder style LEDs that light it up, and you are much better off just replacing the entire thing.

Good luck!

bwwelk
10-11-2006, 06:40 PM
Yeah im talking about the part that has the clock #'s , and radio station lit up ,where it shows these it is all black cant see nothing , so do you think it is just the bulb or bulbs in it?????If so im prob. gonna try fixing it...