Very High Idle on my '03 GAGT [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Very High Idle on my '03 GAGT


kn0
11-22-2006, 10:24 AM
I've kept up regular maintenance on the car, and it hasn't given me too much grief engine/power train-wise. Granted ive replaced 2 windows, and the regulators and such but oh well. For about a week now when accelerating the low coolant light yells at me for a few seconds, than goes away. Last night my car started idling really high, normally at around 1800 RPM in neutral and about 12-1500 in drive. it went as high as 2500 in neutral and 1800 in drive, sputtering when shifting. The car has 34000 miles on it, and the transmission has been fine and still feels fine when driving. I dunno if the Low Coolant is related in anyway to the high idle. It wasn't idling high this morning but i hafta ;crap wait until Monday to bring my car in... *sigh* If anyone could shed some light on the situation before I pull hair out of my head, it would be much appreciated.

Happy Turkey-Day and thanks for taking a peek. ;crap

Treviathon
11-22-2006, 10:33 AM
I had the same problem when the dreaded LIM bug hit. I'm on my 3rd set of gaskets for the LIM(Lower Intake Manifold)!! Common problem, check the seals and see if there is any oil around them, also check to see if your oil looks milky (coolant mixed with oil).

Trev

Sprucegagt
11-22-2006, 10:34 AM
Sounds like a TPS is going bad causing your high idle. Low coolant is caused by just that, low coolant. It will show up under acceleration because as RPM goes up, your spinning the water pump more, making it draw more coolant.

EDIT: Yeah LIM gasket could do it to.

kn0
11-22-2006, 10:39 AM
Thanks for the quick responses guys, Does it help or hurt that I use Full Synthetic?

Kdawg207
11-22-2006, 10:39 AM
just to back up prior posts

i had this too back a few - was the TPS

Sprucegagt
11-22-2006, 10:47 AM
Thanks for the quick responses guys, Does it help or hurt that I use Full Synthetic?
Help

kn0
11-22-2006, 10:55 AM
Cool, hopefully they diagnose the problem properly and fix it, its very depressing. Thanks for the input guys, gobble gobble:applause:

error
12-06-2006, 11:26 PM
my 01 has been doing the same thing the guy i took it to said it was cuz the erg valve has had errors he said replacing the erg valve would fix it i havent done it yet but when i do ill let you know how it turned out