Hello [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Hello


Schmerge
01-02-2007, 08:47 PM
Hi Guys, Just picked up my 01 GAGT this weekend for my daily driver. Figured I would join since i've been in the online forums for a while.

Previously owned a 94 Chevy Beretta which was modded decently.
Mods on the Beretta included:
3400 Swap (out of an 03 Alero)
Fenderwell CAI
P&P UIM
FFP UDP
2.5" Mandrel bent exhaust
FFP Poly Dogbone
Rk Sport Upper Poly Insert
Had quite a bit of suspension mods.
Anyhow i'm forgeting a few things but thats the old car.
Best time 15.2 @ 90.xx with a 2.2 60'

Anyhow I'm loveing the GAGT. One thing I've noticed though. The car was orgionaly sold in Canada. When it was imported it got the cluster switched. However instead of getting the 150mph GT cluster it has a 120mph SE cluster.

00GT1
01-02-2007, 08:55 PM
welcome

ryanbgb22
01-02-2007, 09:18 PM
i believe someone else on here had the same cluster problem.

Rich
01-02-2007, 09:54 PM
yeah coupe had the same issue. thats funny. what plans you got for the GA?

Schmerge
01-02-2007, 10:00 PM
yeah coupe had the same issue. thats funny. what plans you got for the GA?

Ahh its hard to say. I want to mod it since theres such an aftermarket that i was never use too but I drive close to 100 miles a day so I think I'm going to hold off on the modding for a year or so.

williamGT
01-02-2007, 10:04 PM
Welcome to the site.

Rich
01-02-2007, 10:11 PM
Ahh its hard to say. I want to mod it since theres such an aftermarket that i was never use too but I drive close to 100 miles a day so I think I'm going to hold off on the modding for a year or so.


you should pick up one of the SC's for sale. perfect for a DD!

LoboMan7409
01-02-2007, 11:54 PM
Welcome

'01GT
01-07-2007, 02:33 PM
*welcome*

coupe
01-08-2007, 11:44 AM
Hi Guys, Just picked up my 01 GAGT this weekend for my daily driver. Figured I would join since i've been in the online forums for a while.

Anyhow I'm loveing the GAGT. One thing I've noticed though. The car was orgionaly sold in Canada. When it was imported it got the cluster switched. However instead of getting the 150mph GT cluster it has a 120mph SE cluster.

Yup, i got the same problem, if you consider it a problem.
Damn canadians hehehehe