Intermintent stalling and sputtering [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Intermintent stalling and sputtering


Cooper96gt
01-21-2007, 05:06 PM
Okay so I just bought the car a week ago. I took it on a highway trip about two hours long and on my way back the car starts sputtering and the lights on the dash are coming on and off like there's low voltage.. so its sputtering and i pull off the road. it wont start back up and when i do put it in the run positon the fuel pump turning on is intermintent as are the dash lights and when it does get started the rpms idle at a grand and then drops. Also when in the run position the volt, speedometer and tach needles would jump up and down like it was a loose wire problem .when i do get it running and it is sputtering like that the theft system light stays on. and everyonce in a while it would let me go a few miles then the same ole stuff but the theft system light would be off.also. My mechanic suggested it may be an ignition switch problem and to wiggle it around when it started stalling. That didnt work eiter. i stopped at my mechanics on the way home. It sounded like him to be the battery terminals so we cleaned thbose and took it for a test drive and of course it ran like a dream. I leave his garage and head home another ten miles just as i pull up to a stop light it dies and i cant get it started again. so i push it off the road. And it wouldnt start for a good two minutes then when it did it ran fine but the theft system light stayed on till i got home and turned the car off then started it up again and the light disappeared. I still think this is an electrical problem..anyone have any idea's???

gectek
01-21-2007, 05:16 PM
prob fuel pump i think, has happend in a similar situation to me on a few vehicles

Cooper96gt
01-21-2007, 05:23 PM
see thats what i was thinking. but at the same thime the "dash lights" ya know like the abs, check engine, low oil,etc. all of those warning lights would flash like low voltage problem. But since i do think its electrical would it possibly be a fuel pump relay or something and if so are there any ways to test it?

gectek
01-21-2007, 05:33 PM
well u also notice that those lights come on when the car is started...because your car is dead, so the gauges light back up, on my 85 olds it would do the same thing, when the car would die, the oil press light, ses, batt and a whole list of others would come back on. the only way to test is to check for fuel press and fuel volume really...or change out with NGP(known good part)

Cooper96gt
01-21-2007, 06:06 PM
yeah its just really strange. its just weird how the lights flash in and out like an electrical cutoff. I have two mechanics doing some research on it but would like all the help i can get out there fellow Gt'ers

Sprucegagt
01-21-2007, 10:09 PM
When was the last time the fuel filter was changed?

Cooper96gt
01-22-2007, 07:29 AM
thats a nice thought. but the way the guages and needles jump up and down randomly when I just turn the key to run makes me want to rule out it being the fuel filter. My first vehicle was a 1951 chevy truck with a five window cab that had fuel filter problems because the truck had been sitting for a long time and apparently got junk in the tank for the fuel filter would clog up and the way it would act in not compareable to what my gt is acting like. Im still leaning towards an electrical issue anyone else have any suggestions on what they thinking it might be?

gectek
01-22-2007, 10:41 AM
well that 51 is on a completely diff system, your grand am runs alot higher press and alot more volume, so anything in the line even a small grain is a big restriction. its always a good idea to change that often anyway, just use a high quality filter, like delco or wix.

Cooper96gt
01-22-2007, 02:19 PM
very true! but the way the needles are bouncing around along with the wwarning lights coming on and off makes me think its an electrical short. I have to hire an attorney for some legal matters so I will hold off the tune up for a a month or so. by the way your gt is sharp. How come you havent put the clear turning signal bulbs in yet?

gectek
01-22-2007, 02:58 PM
thanks alot. dont feel the need to, i like it just the way it is lookswise, my bro took the ribs off one weekend when i was on vacation, so im getting those back soon. and the gt sideskirts. i am workin on repainting the interior and getting new carpet and the redline shift boots. and id rather it go fast than look r!ce...lol

Cooper96gt
01-22-2007, 03:57 PM
oh that reminds me! So I went partyin this weekend and stayed with some friends. One of their friends had a newer style gt like a 2004 or so. So instead of wanting to make his v6 sound like a v6. He puts two ricer mufflers on his gt..something you see people putting on civic's. I laughed so hard! Congrats on making your v6 sound likea 4cylinder lol

Cooper96gt
01-25-2007, 08:40 AM
UPDATE: So Im at the bank in the drive thru idling. Then my car dies I try to start it and nothing cranks but wont fire so embarrasingly push it into the parking lot..When I turn the key I dont hear the fuel pump at all and the issue with the dash lights and needles sporadically freaking out is going on. So At that point im thinking fuel pump. so I go back to work and come back to my car three hours later. Turn the key and it fires right up. WTF? So that night I take it to my mechanics and he puts a scanner on it and finds no trouble codes. Im going to have him test the fuel pressure tonight but the way the warning lights and needles on the dash jump up and down makes me think its electrical. I thought I bought a reliable car but its not turning out that way. Anyone have any ideas on this one? It would be greatly appreciated!!

gectek
01-25-2007, 11:00 AM
id def say fuel pump, and watch out for the prolonged cranking when it wont turn over and provide fuel, you can get the engine in all sorts of bad places then, i even fried my ICM due to me cranking it over and over...dont ask me how, i just saw a melted connector and it was new ICM and pigtail time

Cooper96gt
01-25-2007, 11:02 AM
does a bad fuel pump cause the electrical problems i described???

gectek
01-25-2007, 11:05 AM
it can if there is increased current load, also did you say that when you crank it, it will dim the lights and the gauges will flash...sounds like normal operation of the starter, but maybe a high current draw on that too, it check elec. conn and wire to the starter from the batt. and the fuel pump im almost 90% sure, its been a while since i worked on a pre 99 GA, but they are really all the same pretty much

when you turn the key on and off, i think the gauges and lights do a self test to make sure they are working, maybe this is what you are seeing

Cooper96gt
01-25-2007, 11:16 AM
the lights dont dim the warning lights like abs, low fuel,you know the warning lights that come on before the car starts go off and on like nothing i have seen before it really act like there is a electrical short if you can picture that. like even the speedo will jump up and down while the key is in the run position like its not getting enough volts then jumps then loses power i guess would be the best way to describe it.

gectek
01-25-2007, 11:19 AM
ok, well if you have a repair manual or alldata, i would check any common source of wiring, like a power or ground wire, thats what it sounds like to me. i dont have a manual for that year, srry

Cooper96gt
01-25-2007, 11:28 AM
This weekend I think im going to clean the engine and body grounds and hopefully one is badly corroded and thats the cause of my problem. theres just so many things this could be. Can anyone rule out the ignition switch?

Cooper96gt
01-25-2007, 01:50 PM
This car is straight up driving me nuts! I go to get in my car on my lunch break and it wont start just cranks like it did before. But the good part is the warning lights or whatever you wanna call them didnt freak out like i mentioned before and neither did theneedles. So turning the key from off to run sometime the fuel pump would run but most of the time it wouldnt i herd it maybe 8 times out of 20 or more...so i get under the car and beat on the middle-bottom of the fuel tank where the fuel pump is per suggestion from my mechanic. It didnt help. I would turn the key and not hear the fuel pump then in between my 15 or 16 attempts it came on twice but wouldnt start so im thinking its gotta be the fuel pump. I come back an hour later from lunch and it fires right up. I test it going from off to run many time and hear the fuel pump everytime. Im thinnking the fuel pump is the culprit now. what do you think?

gectek
01-25-2007, 05:56 PM
fuel pump time, also maybe check the relay and always replace the fuel filter when u do the pump

Cooper96gt
01-26-2007, 07:38 AM
Got a check engine light on the way to work this morning. Ill let ya know what code was thrown.

Cooper96gt
01-26-2007, 02:16 PM
code is P0440 evap code...i did some research and its common occurance is when the gas cap is loose.. which mine is because alot of the ttime my car was acting up i loosed the cap and it seemedto help.so stil looking for the culprit it sounds like ...blah!