GOt a code..P440....umm anyone know what to do?? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : GOt a code..P440....umm anyone know what to do??


97PGAMGT
02-15-2007, 07:12 PM
Like how can I diagnose this problem...the book says EVAP System Malfuction...but i dunno what the hell that means....

lone_wolf025
02-15-2007, 07:44 PM
Check your gas cap make sure its on til it clicks. Beyond that check your evap system. Should be a diagram under the hood for it. Make sure all lines are connected.

Check the link. Has some pointers: http://www.obd-codes.com/trouble_codes/generic/p0440-evaporative-emission-control-system-malfunction.php

gectek
02-15-2007, 11:26 PM
usually gas cap, and even if it clicks it can still be messed up. cheap ins is to get a new one if you have had this one for any long length of time. also the evap codes are a PITA, the elbow that goes from the solenoid to the PCV T hose that goes in the top of the intake likes to get crumbly, so that could be a cause, but the evap system can detect a leak as little as .020 in, about the size of a pin hole, so its really hard to check them without a smoke machine. if you do pressurize the system to check for an air leak, DO NOT use over 15psi on the line as it will cause alot more problems than u need. also you might check the charcoal canister to make sure all the fittings are on good and in good condition. if you have any suspect lines i would def replace them, if you dont use stock replacements, if u just wanna get hose, make sure you use the hose rated for evap systems.