rpm gauge up and down [Archive] - GrandAmGT.com Forum

PDA

View Full Version : rpm gauge up and down


ramairgt19
03-28-2007, 08:04 PM
hey guys started the car today and th rpm gauge went nuts up then down up back and forth and when it went down felt like the car was going to die....when driving no problems at stop signs or red lights no problems so what could it be

GodsendGAGT
03-28-2007, 08:13 PM
when mine did that it was the thing with a 2 and a 5 on it i fforget wat it was called...lol also it could possibly be the mass airflow sensor thats wat was wrong on my friends

ramairgt19
03-28-2007, 08:19 PM
you know roughly the cost of the mass flow senser? if it needs to be replaced? not that good with cars could you do it on your own

SkiZZor
03-28-2007, 08:48 PM
I have the same problem every now and again...but it happens very randomly. Usually when I am driving for awhile, turn it off, and then turn it back on again, the RPM will jump from 1000 down to 200 frequently. After about 30 seconds it will level out at 500, but sometimes the car actually turns off.

drumking1721
03-28-2007, 09:12 PM
Yea happens to me as well. I jsut rev the car to about 1500 and it stops

Jake
03-28-2007, 10:20 PM
Yea happens to me as well. I jsut rev the car to about 1500 and it stops

Same.

GA Nightmare
03-28-2007, 11:48 PM
Same issue, especially over 70mph. Replaced my fuel filter. No more problems.

Sprucegagt
03-29-2007, 06:31 AM
hey guys started the car today and th rpm gauge went nuts up then down up back and forth and when it went down felt like the car was going to die....when driving no problems at stop signs or red lights no problems so what could it be

My first thought would be a TB sensor going bad.

ramairgt19
03-29-2007, 06:32 AM
sorry whats a tb sensor?

gectek
03-29-2007, 03:37 PM
tuberculosis sensor, itll give a bad signal when your car starts to cough....well really he means a throttle body sensor, like Throttle position sensor or idle air control sensor. i think it may be just a dirty mass air flow sensor, get some MAF cleaner and clean away, if not then it might be a failing coil pack or ignition control module