po420 help please [Archive] - GrandAmGT.com Forum

PDA

View Full Version : po420 help please


gobraves00
05-22-2007, 12:36 PM
i have been replacing all gaskets in engine bay, i had a really bad leak causing coolant and oil to mix, so i tore apart eh engine and have been replacing all gaskets and also replace both cylinder heads(this was the problem). once i put eveything back together it started up great and drives alot better. went to get emissions done and they said i had to drive it around for awhile before they could pass me since i disconnected the battery. so while driving it around my check engine light came on, went back to my dads shop and got a po420 code, which talk about the catalytic conv. i know the check engine light was not on so i am leaning towards other related issues that would cause this code. the only thing i can really figure is the ehaust wasnt attached to the manifold to ensure no leaks, i didnt tighten them down at the same time, so i think it might be offset. before i start tearing things apart again i was wanting to see if anyone else could shed some light on this for me.again, the check engine light was not on when i began to work on the car, and the only thing i did was changed all gaskets in engine.

black05GT
05-22-2007, 12:57 PM
First thing that I'd check would be for exhaust leaks from the manifolds back to the O2 sensor behind the cat. convertor. Exhaust leaks can make the "mix' look more lean than it really is. By chance, did you happen to put in a high-flow cat convertor while you had the engine work done ?

Sprucegagt
05-22-2007, 01:11 PM
P0420 centers around the rear O2 sensor not recognizing the catalytic converter. Make sure you have no exhaust leaks and as black05GT said, did you install a high-flo cat?

gobraves00
05-23-2007, 01:04 AM
no i did not install that