tire rub [Archive] - GrandAmGT.com Forum

PDA

View Full Version : tire rub


jnugg69
09-07-2007, 06:23 PM
Just got a new set of struts and springs installed today at the garage. Now my tire makes a rubbing noise faster and slower right with the tires as they spin. It sounds like it's the driver front tire. It worries me a little cause I don't wanna wear out my tires.

jnugg69
09-07-2007, 07:25 PM
Now I just observed, it seems like the tires are rubbing on the strut a little. They look like they're like touching each other as the car is sitting still. The garage put in the monroe quick struts. Is there a way to put them in wrong and have them rub, because it didn't do that noise before with the broken springs and struts I had. Thanks a lot.

stewartfn18
09-07-2007, 10:12 PM
if its the stock size tires, i dont know what to tell you. My friend has a GP thats dropped and it doesnt rub. not the same but close enough.

alerored04
09-07-2007, 10:21 PM
you normally need an alignment after new struts are installed. Are they toed out really bad? Pics would help.

jnugg69
09-07-2007, 10:58 PM
I can see where it's rubbing. It's right on the steel basket that holds the spring. I'm taking it back to the garage tomorrow. My cousin said they could grind down that basket a bit to stop the rub. I'm going to get the alignment shortly here, but it never rubbed before and I had broken springs and everything.

alerored04
09-07-2007, 11:27 PM
huh, thats weird.

ancona46
09-09-2007, 07:50 AM
u need an alignment

nate2023
10-04-2007, 11:20 PM
make them replace the struts, maybe you got a manufacture defect or somehow they put it the wrong part, its rare, but stuff happens.