Help with engine please!! [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Help with engine please!!


hyperjiz
09-30-2007, 02:05 PM
So recently I did a tune up with new plugs and wires, shortly there after I started getting this weird smell (almost like a lawnmower) coming from the engine bay, and creeping into my vents? I have look through all of the threads and can't find anything on this. The smell seems to be only apparent when the cooling fans are running. Please help with this problem.

P.S The smell is most apparent to the right of the alternator.

-Matt

WeibSunder
09-30-2007, 03:50 PM
Q #1: Does it smell like burning plastic?

Q #2: Did you happen to mess with any coolant hoses or radiator hoses and possibly spill some antifreeze on the engine?

hyperjiz
09-30-2007, 05:13 PM
It smells like an exhaust fume or gas not like burning rubber or plastic, I had my mechanic check it out for me and he said all of the injectors look fine and the catalytic converter would make my car run bad if it were clogged. I didn't spill any antifreeze anywhere.

Will having the L.I.M leak make my car have an exhaust smell? I've already had the job done once by the dealership, I'm really hoping that I don't have to get it done again.

I have no idea what this issue could be and I've been on this forum for years so I know that people on here know just about everything there is to know about GA's. Any help and input is greatly appreciated.

drumking1721
09-30-2007, 05:22 PM
the lim shouldnt make your car smell like that. I have a similiar issue right now,i just put on my ported intakes and spacers,and it smells a little,im not too worried about it

hyperjiz
09-30-2007, 06:42 PM
It's just very weird that I have never had this problem until I changed my plugs and wires. I took it to someone yesterday to do the seafoam and it was smoking for a good 5 min straight, so everything is cleaned out and the car feels like it has more power. But I just want to know what/where the smell is.

Update: If I smell in between the manifold (I believe its cylinder 1, closest to the alternator) if i smell right where the 3 is (3400) the smell is coming from right there. Any suggestions? This is so frustrating

drumking1721
09-30-2007, 06:49 PM
check any make sure all your vacuum lines are connected and or broken. It could be that.

Panacea
09-30-2007, 07:53 PM
Is there splatter on the hood above the serpentine belt? If yes, then it may be your water pump.

iceman
09-30-2007, 08:12 PM
http://www.grandamgt.com/forum/announcement.php?f=22