Need a second opinion, no heat [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Need a second opinion, no heat


Firebirdnyc
11-26-2007, 06:13 AM
I have a 2000 grand am gt, now my heat worked excellent till about this year. I noticed this summer that when i am in the Hot position and turn the fan speed on 1 i had heat but it would go away real fast. So one night i did the same thing turning it on and off and noticed that the A/C light would flicker when i turned it on, so it was obvious that the a/c compressor was running even with the heat in the on position thats why i would get no heat now is this normal?? also my blend door makes a wierd noise when switching from cold to hot and even though i pulled the a/c compressor relay my heat sucks, Where should i go with this? i have to wait for my car to get up to like 230 to get real heat 200 and its just warm

WeibSunder
11-26-2007, 06:33 AM
Maybe a bad heater core?

bigstribs
11-26-2007, 08:26 AM
that sounds about right

Firebirdnyc
11-26-2007, 11:38 AM
yeah thats what i was thinking of, great anyone do a heater core on these grand am or would i rather stay cold haha

howlinwolf
11-26-2007, 11:56 PM
how about this, go to an autoparts store, buy a coolant flush, and a kit, flush the system first. normally this will clean it out. ive never heard of a "bad" heater core, unless it leaks. mabey clogged though. also, check the coolant level.

Firebirdnyc
11-27-2007, 05:47 AM
yeah i think it might be restricted , i did my upper radiator hose the other day and the walls of the hose was completely covered in scale. I guess i should try a flush kit.

pontga00
11-27-2007, 06:35 AM
Does the blower blow out any air at all? I had an issue with mine just blowing out just cold air. I replaced the blower motor and problem was solved.

Firebirdnyc
11-30-2007, 05:37 AM
the blower motor does work, it blows warm then gets cold right away. For some reason all my cars end up with no heat. my luck