Evap and Egr Still "Not Ready" Inspection [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Evap and Egr Still "Not Ready" Inspection


sonicfrequency
02-06-2008, 12:20 PM
Hello GAGT'ers. Hopefully someone can help me with this issue. At the moment I have an elmscan5 connected to my laptop and Im using PCMscan. I have no error codes and my mil light is clear. I've traveled ~250 miles in my car and have tried the OBD2 cycle tips with the acceleration and coasting and cold start idle. I have 3 monitors that are ready: Catalyst, Oxygen Sensor, and Oxygen Sensor heater. I need 1 more to trigger ready for inspection.

The pontiac dealership says that it could be a bad pcm. Is this true? I thought the PCM would throw an error code if it was bad itself. My codes are all clear.

I originally had a P0442 code. My gas tank was dropped and smoked to fix the seal around the Fuel Sender. This was about a $250 job. Now the monitors wont ready up for inspection!

I reset the system by both pulling the fuse under the hood and disconnecting the negative on the batt. Total miles put on this vehicle without codes ready ~500.

Do I really need to replace this PCM or is there another issue here? Thank you gurus for any help at all. :leg

mattamd_xp
02-06-2008, 05:45 PM
both of those tests are performed while cruizing at highway speeds -try doing more highway and see if that helps -I had the same problem on my 99 and it took over 700 miles after the batt disconnect to perform those tests (and that was 80% highway)

sonicfrequency
03-02-2008, 04:25 PM
Just an update. Its true. I had to wait ~700 miles for the sensors to read ready! And Im really happy because the Pontiac dealerships themselves said its a bad PCM and theyll have to replace it for ~$300. So yeah....anyone else with a not ready OBD code for EGR and EVAP, wait for 700 - 800 miles! Thank you once again GAGT!

PhantomLover007
03-03-2008, 02:23 AM
Man. I'm glad that I don't have to worry about car inspections in GA. Had to when I lived in LA though. It was a PITA.