Popping (clunk) noise in front when turning [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Popping (clunk) noise in front when turning


tiger78187
02-24-2008, 05:48 PM
I have an 03 Alero GLS that makes a popping noise when turning. It doesn't always happen. It does make a louder noise generally at slower speeds when it does happen. I was wondering if anyone else had this problem.

Thanks

Tonyyank
02-24-2008, 05:54 PM
sounds like it could be a wheel bearing. Others will chime in too.

Sean
02-24-2008, 06:22 PM
it may be a loose caliper..i bought my car used and when i went to go check out the problem, i found that that it was sliding back and forth along the rotor. Made a terrible clunking noise and my brakes didn't work all that well. I ordered a new mounting bracket that was it..

LukeL
02-25-2008, 05:04 AM
sounds like it could be a wheel bearing. Others will chime in too.

Wheel bearings generally cause a vibration not a clunk. This is more of a strut problem.

Check the spring itself on both sides. I had a broken spring and I would hear a clunk when turning because the spring was twisting inside the shock tower. Scary stuff. Or, the bearing plate on top of the strut could be worn.

Get a quick strut assembly to fix it if your car is not lowered.

Panacea
02-25-2008, 06:14 AM
Could be tie rods. I had mine replaced twice.

stewartfn18
02-25-2008, 06:18 AM
something could be broken inside the rack and pinion assembly.

awfulwaffle
02-25-2008, 08:57 PM
sounds like a tie rod end. Had the same thing happen on a friends van, replacing the tie rod fixed it.

jurgs2007
03-02-2008, 06:06 AM
yea, i had that happen to me with the tie rod, but if thats the case, you front end will wander wherever it wants to because your front end will be loose. another possiblility could be your suspension. i had my drivers side front spring break and whenever i turned it would make that clunking sound too. there are soo many possibilities. just have to jack the front end up and start searching.

thormxkid
03-02-2008, 12:27 PM
im ganna say a cv joint or a strut mount bearing....i just replaced all the things everyone is metioning and i still got the prob...should be fixed soon tho im bringing it to the shop to get checked out tuesday

tiger78187
03-04-2008, 10:04 PM
im ganna say a cv joint or a strut mount bearing....i just replaced all the things everyone is metioning and i still got the prob...should be fixed soon tho im bringing it to the shop to get checked out tuesday

I am going to start searching on Saturday, If you find out what it is on your car please let me know. Thanks again for all the advice. I will let you know what I find on Saturday.

tiger78187
03-09-2008, 12:38 AM
Update:

I finally put my car up today and found out that the cv joint is making the noise replaced it and problem solved. Thanks again.

thormxkid
03-09-2008, 12:42 AM
no prob