Strange gas tank problem [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Strange gas tank problem


jduce
03-15-2008, 10:46 AM
Here's my problem. I have an EVAP code - no big deal, car runs fine.

I have changed the gas cap. I still get the code.

Occasionally though, I can't put gas in the tank at all. At the pump I begin to put gas into an empty tank and it'll instantly click off. I tried to pump it in slowly and it overflows. I know for a fact that the tank is empty because I monitor trip mileage on each full tank.

What is my problem and how can I resolve this?

Thanks for your time!

Graxall
03-15-2008, 10:50 AM
Here's my problem. I have an EVAP code - no big deal, car runs fine.

I have changed the gas cap. I still get the code.

Occasionally though, I can't put gas in the tank at all. At the pump I begin to put gas into an empty tank and it'll instantly click off. I tried to pump it in slowly and it overflows. I know for a fact that the tank is empty because I monitor trip mileage on each full tank.

What is my problem and how can I resolve this?

Thanks for your time!


You pump gas into a empty tank and it overflows?...that is what i got out of it. If you mean you pump and it gets full and over flows then uhm..duh lol...

eve
03-15-2008, 10:53 AM
No, I think he meant he knows his gas tank is empty, but when he tries to fill up, his gas tank for some reason doesn't acknowledge it and it overflows.

Graxall
03-15-2008, 10:55 AM
No, I think he meant he knows his gas tank is empty, but when he tries to fill up, his gas tank for some reason doesn't acknowledge it and it overflows.

Well if thats the case, then the ball or whatever inside your gas tank is either stuck or broken and not working correctly. Sometimes i get a weird thing where ill be on empty, fill my tank, and it will shoot up to full then back to empty and go up as i start to drive...

jduce
03-15-2008, 01:47 PM
Yeah, I've done some research on this issue. I found a site where it talks about a flapper valve and a evap management valve.

I'm going to see if I can get them cleaned out or replaced.

Here near Flint, MI there is a Gas Tank Renu. I'm sure they've encountered this problem.

Malaclypse
03-15-2008, 02:00 PM
Its more than likely going to be your EVAP Vent valve which is separate from the tank. It normally vents pressure from the tank and does the same when you're filling. If its stuck closed it will cause this problem.

The other possibility is something blocking the check valve. I'd put money on the vent valve if you're getting an SES light as well.

rustyballs_69
03-15-2008, 05:08 PM
Yep, its either the valve or a blockage in the line.

jduce
03-15-2008, 07:29 PM
Its more than likely going to be your EVAP Vent valve which is separate from the tank. It normally vents pressure from the tank and does the same when you're filling. If its stuck closed it will cause this problem.

The other possibility is something blocking the check valve. I'd put money on the vent valve if you're getting an SES light as well.

Thanks! I'll look into it

Do you think driving around with a bad evap vent valve will cause engine problems?

Malaclypse
03-15-2008, 07:38 PM
Thanks! I'll look into it

Do you think driving around with a bad evap vent valve will cause engine problems?

Only a check engine light and hard filling at the pump. Other than that you'll be fine to drive on it as long as you can stand the 1/2 hour it takes to fill the tank.