2001 G Am Questions [Archive] - GrandAmGT.com Forum

PDA

View Full Version : 2001 G Am Questions


john1962
03-25-2008, 12:37 PM
I bought a 2001 Grand am for my son and I had a couple questions about some minor flaws that came with it 1) what would cause the windshield washer fluid light come on periodicly even though it is full
2) The change oil light is on even though it has plenty of oil and its not due for a oil change yet, Ive tried the reset button in fuse compartment, but it doesnt reset 3) The car always runs at a temp of 200 to 220 even when you first start driving it what is the normal temp its a 3400 eng with 108000 miles......................thanks for any info,

Tonyyank
03-25-2008, 12:42 PM
alot of these topics have been discussed on these forums before

Click on here and search for you answers http://www.grandamgt.com/forum/search.php

GA2000GTSpeed
03-25-2008, 12:59 PM
Well the Sensor for the windsheild washer fluid could be bad or dirty. but nothing really to worry about.
the change oil light will get reset when you get the oil changed by the mechanic.
and normal temp is about 200 when ur driving.

Tonyyank
03-25-2008, 01:04 PM
Well the Sensor for the windsheild washer fluid could be bad or dirty. but nothing really to worry about.
the change oil light will get reset when you get the oil changed by the mechanic.
and normal temp is about 200 when ur driving.

1. Yes
2. No http://www.grandamgt.com/forum/showthread.php?t=987&highlight=change+oil
3. Yes

john1962
03-25-2008, 01:06 PM
Thanks ,I will do some searching and reading...................

Tonyyank
03-25-2008, 01:06 PM
No problem!!

Jake
03-25-2008, 01:13 PM
No problem!!

Oh mai godz u r lyke teh bezt red name man evar tony! :D

KhellendrosxS
03-25-2008, 01:25 PM
I bought a 2001 Grand am for my son and I had a couple questions about some minor flaws that came with it 1) what would cause the windshield washer fluid light come on periodicly even though it is full
2) The change oil light is on even though it has plenty of oil and its not due for a oil change yet, Ive tried the reset button in fuse compartment, but it doesnt reset 3) The car always runs at a temp of 200 to 220 even when you first start driving it what is the normal temp its a 3400 eng with 108000 miles......................thanks for any info,

As Tony stated there are several years of knowledge here so please use the search function next time.

1) The float in your washer tank is either bad or more likely the connection is dirty. Take it apart (ill leave that to you to figure out) and clean it.

2) The procedure to reset the light is in the owners manual. If you dont have it the answer is here somewhere.

3) That is a standard operating temp for the GA. With the amount of miles it may be time to get the cooling system flushed and new coolant added. Just make sure it doesnt go into the red and you are fine.

While you are researching do a search for 'LIM gasket'. If you ever start experiencing unexplained coolant loss then it is probably leaking and needs to be replaced. There are instructions here if you want to do it yourself or you can pay about a grand to have a shop do it for you.

GA2000GTSpeed
03-26-2008, 01:38 PM
1. Yes
2. No http://www.grandamgt.com/forum/showthread.php?t=987&highlight=change+oil
3. Yes

Well i was talking about that the person that changes ur oil if u take it in they would have to turn the key to the on position and depress the gas pedal all the way and let it come back up all the way three times. within five seconds.
or at least that is wat my dads friend george told me that changes oil for a living.

Ajaxus
03-26-2008, 01:54 PM
Not every garage does that though.