99GAGT Coolant system airlocks [Archive] - GrandAmGT.com Forum

PDA

View Full Version : 99GAGT Coolant system airlocks


huedog
03-27-2008, 04:36 PM
I'm new to the site I and have browsed some of the forums and like all the info. I'm still having trouble answering my questions... So here goes... This GT has me and my mechanic baffelled, you start this car in the morning it overheats and you get no heat out of the heater or defrost... So, we bleed the coolant system and then things are fine for awhile until you shut it off and restart it again...Same thing happens again... Heck from time to time it overheats while driving through town...We have pressure tested for the head gaskets it appears to be ok... We ran a die test that seems to be ok also...i just had the intake gaskets replaced that didn't fix it...Help...Help...Help... I am about out of patients and money.. can someone please help me find the answers to this...

nickofcourse
03-27-2008, 05:22 PM
are the fans and water pump spinning?

huedog
03-27-2008, 05:25 PM
yes and the water pump has been replaced...

gaowners32
03-27-2008, 08:10 PM
This happened to my car check the water pump and the radiator if thats not it then the thermo-stat is stuck either open or closed.

ryanbgb22
03-27-2008, 08:25 PM
You did try replacing the thermostat before you did all ofthat right? Because it sounds exactly like a sticking thermostat.

PhantomLover007
03-28-2008, 12:39 AM
My guess would be the thermostat.

BTW. *welcome*

huedog
03-28-2008, 09:18 AM
yes that was the first thing we replaced.. crazy isn't it. all of the obvious stuff hasn't fixed the problem.. i appreciate all of everyones suggestions though simple or not, we for sure could overlook something... thanks for the replies and suggestions... keep them coming something is bound to work... thats the reason i joined this site...