Signal Buzzing Sound [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Signal Buzzing Sound


ramairgt19
03-31-2008, 12:29 PM
i know its been talked about in prev post but just wanne make sure.whenever i wanne turn left or right and i pull on my signal gives a buzzing sound so loud and so annoying .it only comes on with i wanne turn right or left.lately now it doesn't even make that buzzing sound and no signal lights comes on either just dead.i have to play around with my hazzard lights and **** it get it working....so i am in canada i think the dealer roughly charges $200 + which if i can do it on my own i want too...not great with car stuff but there been post just wanne make sure its the same topic so i can get info and do it my self thanks guys

ryanbgb22
03-31-2008, 12:31 PM
I'm pretty sure thats what the recall fixes. You should be able to get it done for free.

ramairgt19
03-31-2008, 01:26 PM
really see i called a few months about they said there was no recall tring to see if i can find any info in the recall maybe if i show it to them

ryanbgb22
03-31-2008, 01:30 PM
for the recall, they replace the hazard switch. I'd bet when you called, they though you were referring to the multifunction switch....(it soudns like this is not your problem)

ramairgt19
03-31-2008, 01:38 PM
ah thanks ok so if i call back and say its the hazard switch and if they give me a hard time saying no is there somewhere like gm site i can see there was a recall for the hazard switch so i could show them

ramairgt19
03-31-2008, 01:40 PM
http://www.tc.gc.ca/roadsafety/recalls/recall_e.asp?recno=11062&make=PONTIAC&model=GRAND+AM

found it

ramairgt19
04-01-2008, 07:41 AM
i called gm to confirm and i was not one of the people who had a recall.so its not covered since my car was never recalled even though i have the same exact issue .little pissed off

ramairgt19
04-01-2008, 12:02 PM
ok i gone nuts with this issue ..i read the how to change the clicking switch on top of steerling panel then i read about the hazard swtich ...ok clicking sound as you guys wrote not sure how to take it mine makes this god awful sound like a buzzzzzzzzzzzzzzzzzzzzzzz whenever i wanne turn and turn on my signal it goes buzzzzzzzzzzzzzzzzzzzzzzzzzzzz i then either turn off my singal and turn it again or turn my hazard switch which stops the buzzz sound then my signal works no problem so i think i need to replace my or clean the one over the streeling panel.....i called napa parts and said they have the replacement part for 10 bucks? but i didn't read where you guys replaced something you guys just cleaned it so not sure what this part he is taking about....anyways i think i will do the streeling panel see what happens if not the car and stay how it is

stingray71
04-01-2008, 01:14 PM
I would replace the hazard switch first since you are planning on doing this anyway. See what happens after you replace the switch. It may or may not be related.

ryanbgb22
04-02-2008, 09:50 AM
I think i remember the dealer telling me that a bad multifunction switch could also cause the hazard switch to go bad. But it sounds to me like its only your hazard switch. REplace that, I'd bet thats your problem.

rohrc
09-13-2009, 04:58 PM
Curious if there was any resolution to this issue about the buzzing issue originally noted by "ramairgt19", possibly somewhere else in this forum?

I have a 1999 Grand Am GT with same issue. If you put the Turn signal ON, the dash arrow and actual signal bulb light up, and stay on solid. No intermittent flashing like normal. There is a constant "buzzing" as ramairgt19 had described while this all occurs. I too tried to press the hazard button ON and OFF, which at first seemed to reset the blinkers from the solid state back to the normal blinking.

As time went by, trying to reset the blinking with the Hazard switch did not work, and actually both signal lights (and arrow lights on dash) would be lit in a constant state (no blinking either) when the Hazard switch is turned on.

Time to time, the blinkers work normally again.

The issue described by mainy others about the "random" blinking and having to clean the multifunction switch is not the same as my issue (in my opinion), as my blinkers (and hazard lights) only come on when I want them to, its just they are on "solid" and do not intermittently flash like they should.

There is the Transport Canada Recall for the Hazard Switch, which says" HAZARD WARNING SWITCHES THAT MAY EXPERIENCE SOLDER JOINT CRACKING CAUSED BY RAPID TEMPERATURE TRANSITIONS AND THE SOLDERING PROCESS. IF SOLDER JOINT CRACKING OCCURS AND RESULTS IN AN OPEN CIRCUIT, THE TURN SIGNALS/HAZARD LAMPS BECOME INTERMITTENT OR INOPERATIVE"

Not sure if the 1999 model was part of the recall (believe 2001 was), nor if my problem fits the description of INTERMITTENT OR INOPERATIVE as they intended.

If ramairgt19 resolved this issue, or anyone has a suggestion about, would appreciate some feedback.

I get the impression there is a relay tied to the Hazard Switch (which is interconnected to the signal switch?), and if so, is that was controls the intermittent flashing of the hazards/signal lights.

Thanks,

rohrc