Weird problem on 97 [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Weird problem on 97


Tank33
04-20-2008, 05:47 PM
Ok. A friend of mine has a 1997 Grand Am with the 3.1 L.

About 3 weeks ago, the car would start, run for a second or 2, and then die. Sometimes it would run for 5 seconds, and then die. Checked fuel pressure, pump, spark, all that, definite OK on those items. So he tried to leave the key on for about 20 minutes to see if it would recognize it and reset, and YES, it finally worked! So the car worked good after that for about a week.

Now, when you turn the key, the gauge needles go nuts and lights flicker on the dash, and when the key is in the ON position, all you hear is a ticking type of noise, and an electrical noise. Once you turn the key to crank the engine over, you get the clicking noise, which sounds like it is coming from a solenoid by the passenger side firewall. Starter will not engage at all, just clicking noise.

What do you guys think, ignition module? How does one replace the ignition module on a 1997 with the 3.1? Any help greatly appreciated, really stuck here.

cardude007617
04-20-2008, 06:10 PM
weak battery?

Tank33
04-20-2008, 08:28 PM
He said the battery was fine, the car only sat for about 6 hours when he tried to start it again, so he got another buddy of his to come and boost him, and even with a boost, the car does the same thing, no difference whatsoever, I am thinking ignition module or ignition switch, some people use both names for same part.

PhantomLover007
04-21-2008, 12:22 AM
Alternator or starter?

Tank33
04-21-2008, 12:27 AM
I am actually thinking, if not ignition module, maybe the solenoid on the starter. I am hoping it is that. I am going to rig up a switch tomorrow, some wire with a alligator clip, momentary switch, another alligator clip on the other end, and manually jump the starter, if it goes, we know it is something ignition, if it doesn't, we know it is the starter solenoid.

Everyone cross your nuts!

ramair4thesoul
04-21-2008, 01:39 AM
Don't have any.

My car done some crazy **** when the switch went bad. It might be that.

Tank33
04-21-2008, 02:04 AM
Don't have any.

My car done some crazy **** when the switch went bad. It might be that.

...well cross something for me please lol.

What did your car do when the ignition switch went south?

ramair4thesoul
04-21-2008, 02:43 AM
It would act like it wanted to start, but never start. Then it would crank out of nowhere. Sometimes it would work fine. Everyone thought it was something having to do with my fuel system. Then it started just ticking when I would try to start it and the electical stuff would act up. The problem was where the switch was going bad, but not completly bad, it was freaking the security stuff out. It sucked.

Tank33
04-21-2008, 12:16 PM
Did you replace the entire ignition switch, like the key cylinder and everything, or is it a module?