a/c running when switched off [Archive] - GrandAmGT.com Forum

PDA

View Full Version : a/c running when switched off


silverbullet51
05-09-2008, 08:03 PM
I'm having this weird problem with my car.

When I first started it up in the morning, I could hear my cooling fans turn on. Which is odd considering the engine is cold. And then I noticed that my vents are blowing ice cold air. Popped the hood and sure enough, the a/c is running. My HVAC controls are not turned to any setting that would turn on the compressor and the a/c on off switch isn't doing anything (the light works) I tested the relay and it seems to be ok and doesn't show any sign of failure. I'm stumped.

any ideas?

with the relay out, i disabled the a/c for now

ryanbgb22
05-09-2008, 09:11 PM
Well if it stops with the relay out, I'd guess its the relay causing the problem.

Malaclypse
05-09-2008, 11:09 PM
Did you have the mode switch turned to Defrost?

Because that automatically engages the A/C to dehumidify the air for defrosting.

stillriza
05-10-2008, 12:51 AM
Did you have the mode switch turned to Defrost?

Because that automatically engages the A/C to dehumidify the air for defrosting.

i didn't know that. i learned something today.

PhantomLover007
05-10-2008, 01:29 AM
^^ Same here Riz.

silverbullet51
05-10-2008, 11:11 PM
Well if it stops with the relay out, I'd guess its the relay causing the problem.

i hope that's the problem, cuz a relay is relatively innexpensive. i'll put a new one in and see if that solves it

silverbullet51
05-10-2008, 11:15 PM
Did you have the mode switch turned to Defrost?

Because that automatically engages the A/C to dehumidify the air for defrosting.

nope, the a/c will run on any setting besides max, defrost floor, and defrost windshield. pushing the a/c button doesn't do anything either.

Malaclypse
05-11-2008, 02:03 AM
nope, the a/c will run on any setting besides max, defrost floor, and defrost windshield. pushing the a/c button doesn't do anything either.

Switch the A/C Compressor relay with your horn relay and see if the horn is on constantly, if the horn operates normally the relay is fine.

silverbullet51
03-04-2009, 09:33 PM
popped in a new relay and problem solved, except max a/c. got a junkyard HVAC control pod and all is well again (old selector knob no longer clicked to different settings).

danielkr
02-27-2011, 10:22 AM
I have the same problem, AC is always on it seems. I haven't actually looked at the A/C compressor, I don't know which of the parts on the engine it is. I only know where the alternator is.

Its just that when I am driving down the street with a warm engine and air comes through the vents, it is warm. Then when I turn on the fan, the engine RPMs change, the vent air quickly cools off and there is no heat. This happens no matter what position the vent knob is turned to.

I pulled two relays from under the hood thinking it would stop the A/C from coming on (I don't remember which two; one was labeled body control and AC and the other was just A/C, I think). It didn't seem to make a difference. This was a while ago that I tried this, and I don't remember whether i tried them one at a time or both at the same time.

What would be the sequence of steps to troubleshoot this problem?

Thanks in advance,

Daniel