fog lights and dash lights out :( [Archive] - GrandAmGT.com Forum

PDA

View Full Version : fog lights and dash lights out :(


dabroncos12
05-13-2008, 12:36 PM
alright so i just got the car about a week ago and everythings been perfect. its 2003 grand am gt with 80k miles but recently my buddy took the stock radio out ( since it was not working and i have a system) and was gonna put my pioneer radio in and when he did 2 wires sparked and now my foglights and ddashlights dont work along with the service somehtign soon light. we checked the fuses and they are good..so idk? we put the stock radio back in for now sinc i still need the dash kit but if anyone could help that would be great

hass
05-13-2008, 12:56 PM
Service something soon light?

Never saw that light in my car.
Must have been one of those changes for the '03 year.


Is it the Service Engine, or Service Vehicle light?
I assume the Vehicle light since the fogs are out.
I don't see how that would trigger the SES light...

Did you check the right fuse?
I think there may be a couple to check.
Don't forget the fuses under the hood.
along with the ones on the side panel by the driver side door.

dabroncos12
05-13-2008, 01:05 PM
haha yeah its the service vehicle soon light. And we checked the fuses in the side panels and under the hood and they looked good. im going to check them again later today but if its not a fuse idk what it would be.

Pauljp
05-13-2008, 09:32 PM
For the 2003 GAGT the foglight relay and 10A fuse "F" is located on the passenger side fuse box on the instrument panel.

The fog lamp switch goes through the Body Control Module (BCM) to activate the relay and your lights.

Hope this helps.

tonySE1
05-14-2008, 12:20 AM
How come you didn't disc. your battery before doing this?

heeroyue2002
05-14-2008, 02:02 AM
dimmer control switch? i rember my friend sparking on his car and he killed something behind the cluster/

ace_332
05-14-2008, 03:25 AM
its your parking lamp fuse under the hood.I think its fuse #45 not quite sure but it will be a blue 15 amp one for sure. check there and the reason why this most likely happened is because the dimmer wire was probably hooked up to the aftermarket deck if this is the case disconnect it. You only need power, ground,acc, and your speaker wires connected

dabroncos12
05-14-2008, 10:40 AM
hank you so much ace. you were right it was blown and i switched it and put a new one in and they work perfect. My friend looked at all the fueses and said they were good but apprently hes a bit slow. but thanks again

dabroncos12
05-14-2008, 10:44 AM
and thanks everyone for the help! :cheers:

ace_332
05-16-2008, 02:37 AM
glad I could help

adam139
12-20-2009, 03:31 PM
I have a similar problem. I have been working on some custom lighting and whatever I did, my interior lamps (dashboard, radio lights, lights under the window and lock buttons etc...)are not working. I already checked the interior lamp dimming fuse (which blew one other time) but it is fine. I also checked the parking lamps fuse but it is fine. I doubt that a wire melted under the dash because it takes alot to do that (but I am afraid that might have happened). Any ideas??

burgett2103
12-20-2009, 03:33 PM
figure i can ask a question here too. you know the backlight for the foglight overlay? sometimes it works, sometimes it doesn't... any ideas?

adam139
12-20-2009, 04:15 PM
to help your problem, you can easily pop out the fog light/dimmer switch board. then unplug the fog light switch and pop out the switch. then pop out the green board...then you can check to see if your connection on the bulb is good or not. maybe even try unsoldering the light and replacing it. otherwise im not sure

KhellendrosxS
12-20-2009, 05:22 PM
figure i can ask a question here too. you know the backlight for the foglight overlay? sometimes it works, sometimes it doesn't... any ideas?

Pop off the dimmer control with a small screwdriver. There is a bulb under there that my not be making good contact. Some other dis-assembly may be required.

I have a similar problem. I have been working on some custom lighting and whatever I did, my interior lamps (dashboard, radio lights, lights under the window and lock buttons etc...)are not working. I already checked the interior lamp dimming fuse (which blew one other time) but it is fine. I also checked the parking lamps fuse but it is fine. I doubt that a wire melted under the dash because it takes alot to do that (but I am afraid that might have happened). Any ideas??

It is unlikely you melted a wire unless you did it before the fuse. The fuse should have melted if the voltage the wire was rated at was exceeded. See below:

If you have a multimeter check to make sure you have current at the fuse and then check it before it goes into the dimmer switch and then check it after the dimmer switch.

heeroyue2002
12-21-2009, 01:10 AM
sounds like what happend to me. all fuses are ok!
new dimmer control module and still nothing,
i ended up jumping a keyed wire(hot when key is turned) to a dimmer wire on my window switches. i can no longer dim the interior lights though.

adam139
12-21-2009, 02:41 AM
It is unlikely you melted a wire unless you did it before the fuse. The fuse should have melted if the voltage the wire was rated at was exceeded. See below:

If you have a multimeter check to make sure you have current at the fuse and then check it before it goes into the dimmer switch and then check it after the dimmer switch.

i checked the voltage coming from the fuse and its definetly not as high as it should be...?? im gonna check the voltage on the wires around the switch tomorrow...

adam139
12-25-2009, 01:35 AM
so i think it might be the body control module. i went to a salvage yard thinking if i found one that worked, i could answer the question whether that is the problem...and actually found another BCM but when i tried it, it beeped at me and the word "locked" came up on my radio...guess ill have to find a different one to try or else ill actually have to pay for a new one which is gonna kill my pocket. if anyone has an idea of what it could be besides the BCM or whatever im open to ideas

adam139
12-29-2009, 08:28 PM
just in case anyone else has this problem and doesnt want to spend $300 like i did to figure out what was wrong, the BCM wasnt my problem nor was the dimmer switch the problem. The dimmer module is the problem. Its just a small piece of metal up behind the steering wheel.

If anyone needs a more detailed description of where this piece is just let me know...it could save you some money to just check this part. (im just getting a replacement from a salvage yard)

heeroyue2002
12-30-2009, 08:43 AM
Module is $25 at autozone iirc

dpedro34
07-15-2010, 10:29 AM
ok so i have the same prob
my fog lights switch and the backdash light dont work, my dimmer doesnt work but it turns on the interior lights when i turn it to the right all the way, when i lock my car, the 4 corner blinkers dont flash, the light thats behind the AC module doesnt work either, my mid lamps or w/e they're called dont work,
anyone have any ideas or suggestions, i dont wanna take it to a dealer WASTE OF MONEY!!

PhantomLover007
07-15-2010, 01:29 PM
Answer is above your post... Check all fuses too.

richie_east
03-16-2011, 07:10 PM
just in case anyone else has this problem and doesnt want to spend $300 like i did to figure out what was wrong, the BCM wasnt my problem nor was the dimmer switch the problem. The dimmer module is the problem. Its just a small piece of metal up behind the steering wheel.

If anyone needs a more detailed description of where this piece is just let me know...it could save you some money to just check this part. (im just getting a replacement from a salvage yard)
How do you access the dimmer module? my lights went out last july after blowing the fuse twice and then never came on again. Ive been trying to fix them for quite some time now. Please help me