ngk g power? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : ngk g power?


cardude007617
05-14-2008, 08:32 PM
i changed my spark plugs tonight to NGK G power spark plugs ( http://www.partsamerica.com/productdetail.aspx?MfrCode=NGK&MfrPartNumber=3403&PartType=960&PTSet=A )
and now it runs rough as hell and im afraid to even move it. any ideas? WRONG plugs perhaps?

Mike Jung
05-14-2008, 08:39 PM
Looks like the right part.

cardude007617
05-14-2008, 08:40 PM
yeah seems that way, my old TR55s ran just fine.... even though they were shot due to my car running rich from a poor choice in thermostat by the owners before me. you think its the plugs?

Mike Jung
05-14-2008, 08:43 PM
yeah seems that way, my old TR55s ran just fine.... even though they were shot due to my car running rich from a poor choice in thermostat by the owners before me. you think its the plugs?
Don't know...

cardude007617
05-14-2008, 08:45 PM
i never thought id see the day mike jung didnt know something lol, idk, it ran fine before i put the new ones in, i guess ill get a new set of the old style tomorrow

Mike Jung
05-14-2008, 08:49 PM
i never thought id see the day mike jung didnt know something lol, idk, it ran fine before i put the new ones in, i guess ill get a new set of the old style tomorrow
Fine...I will just start talking out of my a$$ lol

You sure that the spark plug wires are sequenced (put in the right place) properly ?

Didn't damage a spark plug wire/boot ?

cardude007617
05-14-2008, 09:15 PM
haha i actually figured it out...its fine now... thanks

Mike Jung
05-14-2008, 09:23 PM
haha i actually figured it out...its fine now... thanks
^
& do you care to share ?

lol

cardude007617
05-14-2008, 09:27 PM
i really dont...... hint-
spark plug and a bolt feel alike when you cant see shiz

kse73
05-14-2008, 09:31 PM
i really dont...... hint-
spark plug and a bolt feel alike when you cant see shiz

lol had the wire plugged onto a bolt, did ya now? lol

cardude007617
05-14-2008, 09:33 PM
lol had the wire plugged onto a bolt, did ya now? lol

nah man, i plugged the wire into the wrong bolt...

lol

laxjax13
05-14-2008, 10:57 PM
haha, the back ones are a pain.
How do those compare to the regular tr55s?

I had tr55s in but the dealership swapped them out for stockers when i got my motor rebuilt.
I just ordered tr6's. i was reading up that they are slightly colder so i guess ill find out in a few days how they run.

cardude007617
05-15-2008, 08:25 AM
i dont know if its just having new plugs or what, but i think i like them so far... the entire 4 miles iv driven with em so far. we'll see how the mileage goes. besides G POWER sounds better.... lol

cardude007617
05-22-2008, 08:55 PM
so i got them in now and its been about a week... my mileage sucks. i got like 12mpg for the first half of my tank, driving lightly too... can these new plugs be ****ting up my mileage?

nickofcourse
08-29-2008, 07:11 PM
did you ever swap out plugs, im thinking about getting these but idk. ever found out what was wrong?