Trunk dome lights not working [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Trunk dome lights not working


Smokem
06-21-2008, 04:54 PM
Hi all, I searched previous posts on this and I wasn't able to find info on this... was wondering if anyone came across a similar situation.

I have a completely stock setup and when I open the lid to the trunk, I noticed the light was not working. Swapped in a new bulb, and the light still does not go on. The housing does not show any signs of breakage/wear and the wire harness to the light looks fine as well.

Can someone help me? Is this a trunk switch issue, relay, etc?? I checked the fuses and they all were fine. Interior lights and such work perfect, just the trunk light is inoperative. Is this a common issue with GM's? Maybe if someone can kindly provide what wire does what on the trunk switch (I am assuming the switch is on the lid where it strikes down onto the car body).

rustyballs_69
06-21-2008, 06:34 PM
Check to see if the is voltage at the light.

tenspeed
06-21-2008, 11:46 PM
The trunk light has two wires, one is orange which is always hot and the other is orange with a black trace that is the ground. The orange/black goes to the latch and connects to a black ground wire when the latch is released.

Reverend
06-22-2008, 05:07 PM
I had a similar problem with my GA when I first got it. Had no voltage to the trunk light and I had a problem finding the switch. Mine has a tilt switch attached to the drivers side hinge. It had popped out of the mounting hole and was laying in the bottom of the trunk. Reattached it to the hinge and the light works fine.

CantBeatIt96
06-22-2008, 08:33 PM
my 96 did the same thing and i found out that the wires leading out heated up melted in a spot and grounded itself, and now i just have to replace it, its been out for a while i just placed the lights on the a switch since they are all LEDs and all. lol