No Fog Lights [Archive] - GrandAmGT.com Forum

PDA

View Full Version : No Fog Lights


Haughee
06-27-2008, 11:40 AM
Hey Guys
I was driving the other day at night and I usually leave the fog lights on, and I noticed the light on the fog light control was not lit up. So I check the front end and the fog lights are not working either. So the other day I check the fuse in the passenger door panel, a little corroded, so I swap it out. Still I get nothing. I can hear the relay clicking when I flip the switch, but still get nothing. Anyone have any ideas?

stillriza
06-27-2008, 07:18 PM
Hey Guys
I was driving the other day at night and I usually leave the fog lights on, and I noticed the light on the fog light control was not lit up. So I check the front end and the fog lights are not working either. So the other day I check the fuse in the passenger door panel, a little corroded, so I swap it out. Still I get nothing. I can hear the relay clicking when I flip the switch, but still get nothing. Anyone have any ideas?

If the fuse was corroded, you may want to check the contacts in the fuse holder..the terminals may have been corroded as well? Also, check all your fuses while you're at it.

Also, try and look at the wiring going to the bulbs..I think I read somewhere that if one of the wires was frayed going to the bulbs, then niether would light up, but I may be mistaken.

Maybe someone else can chime in.

Haughee
06-28-2008, 02:56 PM
I will do that. Lately the wiring in my car has been doing strange things. My stupid left turn signal flashes fast even with no bulb out and I really dont want to change out my flasher.

mydmband
07-03-2008, 07:27 PM
Yeah, my left signal is flashing fast too and no bulbs are out. No clue! The car has a mind all its own! I had to replace the fog light relay, mine was crusty and corroded. Cheap fix but it works fine now.