Shifting/Transmission Problem?? Please Help [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Shifting/Transmission Problem?? Please Help


MzLady
09-30-2008, 10:48 AM
I have 99 Grand Am Gt with 73,400 miles on it. The problem I'm having is sometimes when I put the car in reverse it takes a couple of seconds to actually shift and when it does it shifts hard, then when i put it in drive it will take a couple of seconds to kick into drive and when it does it kicks in hard. But when i push on the gas the car kind of sputters and makes a noise sounding like riding over a grate. Kind of like a grinding sound. Has anybody had this problem? Any help would be appreciated, thanks in advance.

gagt Mechanic
10-02-2008, 10:30 PM
I would guess that the noise you hear is your trans saying HELP!!!!!!. I would go to a trans shop and get it checked. until then make sure your fluid level is ok.

MzLady
10-02-2008, 11:35 PM
Yea I'm going to get it checked out tomorrow. I read somewhere that someone else was having this problem and someone suggested that it might be the shift solenoid or the pressure control solenoid. I hope it doenst cost too much to fix.

pgagt2002
10-03-2008, 03:34 AM
yeah mine had a bad iat sensor n the trans was goin crazy but it was fine after i replaced the snsr

hass
10-04-2008, 04:04 PM
how does the IAT sensor affect the transmission?

MzLady
10-05-2008, 12:13 AM
I took it to the transmission place and had a transmission filter kit done. The car is shifting and running fine for now but I was told that in the near future that the tranny is going to go out. Between 30-70,000 miles.