burning coolant smell... what could it be? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : burning coolant smell... what could it be?


blackgt2k
12-17-2008, 07:05 AM
so this past weekend my buddy helped me install a underglow kit. after driving home and pulling the car into the garage i smelled a weird coolant smell. opened the hood and looked around and nothing. no leaks, no drips, nothing. ive been smelling this same smell for the past 2 days now and still nothing. the coolant level is the same. I work at a GM dealership and I've had 2 master techs look at the car at my job and they see nothing. I am confused at to what this might be. Any one else experience something like this? as for the underglow, we followed the brake lines and went no where coolant lines...

zukiracer19
12-17-2008, 07:06 AM
spill any on motor when you put some in???

blackgt2k
12-17-2008, 09:55 AM
nothing man i havent added any in a while. i also had a tranny flush, major induction, and coolant flush a month ago. nothing at all till this past weekend. and when i mean nothing leaking, i mean these techs are saying that they havent see a block as clean as mine. i dont know whats going on

temp is fine.
no weird behavior.
no leaks.
no spills.

i dont know?

Jake
12-17-2008, 10:16 AM
I had a small coolant leak once I couldnt figure out for the longest time where it was coming from until one day I finally found it. Was the small hose thats U shaped on the left side of the UIM i believe it is, it had a cut in it and when it was hot the hose expanded causing it to leak very slightly but when I turned the car off and looked, the hose contracted and I couldnt see it anymore. I say check some hoses.

blackgt2k
12-17-2008, 10:55 AM
so your saying on the p/s of the engine. near the coolant recovery tank. that side, possibly the hose going to the bypass pipe.

350rs
12-17-2008, 03:40 PM
have you checked the oil for any excess milky white oil? if that checks out then its probably nothing more than a small crack in a hose like Jake stated

dmalle02
12-17-2008, 04:09 PM
i to smell coolant and there is no signs of leaks aswel as my low coolant lights comes on for a few seconds and then goes off but its not over heating or anything im thinking maybe its my LIM. you should follow up witht he conclusion if u happen to figure it out.. Good Luck!:)

blackgt2k
12-17-2008, 07:19 PM
techs said that the LIM is not leaking. we lifted the car today and found nothing. the only other thing that i can think of is the heater core. though i havent lost any heat at all?

iceman
12-17-2008, 07:45 PM
Is there too much coolant and it's coming out of the overflow?

350rs
12-17-2008, 07:47 PM
well if your smelling coolant, your either burning it or you have a leak somewhere. have YOU checked your oil? take a mechanics word for things but always look into them yourself. since you work there im sure they are on the straight and narrow with you, but they have no problems spending other peoples money. next chance you get to spend some serious time under the hood with a light do it. look for puddles, small streams behind the block. anything. and everything. places you cant see. stick your hand there or something that would show if it were leaking

blackgt2k
12-17-2008, 09:43 PM
iceman, nothing has come out of the overflow tube. that was my first thought. ive checked both front and rear of the motor on the top and the bottom. no leaks. i had the car on an alignment rack this afternoon for a half hour and we saw nothing. my only other thought is the heater core. i do smell "ocassionally" when the car is stopped at a light a hint of the coolant. though my heat is on...havent lost any power with the heat what so ever.... ive checked the oil, looks good. checked the coolant recovery tanks cap. no bloating of the seal and no white mess or muck.....i dont know what else it could be..