Power steering went out?? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Power steering went out??


zukiracer19
12-22-2008, 11:46 AM
ok so i park my car at my friends house in the parking lot and walk over to his house. I came out it was snowing like hell... i wanted to get home because roads were already bad. well i started my car let it warm up started my way home... i was going around a turn and my front tires started sliding and i let off so it would get traction again... than all a sudden no power steering, so i had to drive home with no power steering, check fluid level, it was fine... still doesnt work.. i take it my pump died?

tenspeed
12-22-2008, 01:21 PM
The shaft seems to break in those pumps every winter. Usually happens when doing doughnuts in reverse in a snowy parking lot.

zukiracer19
12-22-2008, 03:42 PM
I refuse to spin my tires while turning, I'd rather keep my transmission thank you

ryanbgb22
12-22-2008, 07:51 PM
Likely either the pump or the rack. Hope it's the pump.

zukiracer19
12-22-2008, 09:48 PM
the rack???

GA2000GTSpeed
12-22-2008, 10:29 PM
well myn was acting up pretty bad and for about 2 weeks i didnt have any powersteering then i put a whole thing of the lucas powersteering stopleak or whatever its called and it worked fine, its worth a shot, alot cheaper then a new pump

cardude007617
12-22-2008, 10:58 PM
ugh sounds like what happened to me LAST winter. is the fluid moving at all when the car is running? thats a good way to tell if the shaft broke (which is what happened to mine) gl

zukiracer19
12-22-2008, 11:19 PM
well before it was winter, there was always a clunk in my steering.. thats gone.. along with power steering lol.

zukiracer19
12-22-2008, 11:19 PM
shaft as in power steering pump?

deetz
12-23-2008, 01:53 AM
ya it breaks off the pump inside, mines making a horrid whining noise, just been too lazy to fix it lol, i dont feel like replacing the serp belt either due to having to take off the motor mount