Car acting up with moisture / when raining? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Car acting up with moisture / when raining?


Jake
12-27-2008, 04:06 PM
Had a problem the other day with my car stalling out in heavy rain, mainly at idle, had this problem before as well but only once a while ago. Never hit any puddles or anything, just driving through the rain. I figured it was my CAI getting to wet, and the other day when it did it, I looked at the filter and it was like 1/2 ice and dirt lol so I "recharged" it today. Car was fine around town until I was almost home and it did it again. Well it stalled at a stop light. It restarted with no problem and it was fine until a little down the road I got on it and it was fine until about 4000 RPM's then it started struggling again, but any RPM's lower then that were fine. I also have the vents in my hood open, the stock black plates are gone, so I figured maybe it could be a sensor(s) getting wet. I drive the couple more miles home and I pull in my driveway and now the car doesnt stall and is fine, so I rev it and rev it and it won't die like it was before, so I check under the hood and there is no visible moisture on any sensor and everything appears normal. Any ideas? Even though I recharged the air filter could it still just be getting too wet and maybe " starving" the car of air, not necessarily sucking up water? I am kinda stumped but I am thinking that that must be the reason.

zukiracer19
12-27-2008, 11:02 PM
mine did this... think it was my maf sensor... moist air and water from my CAI was getting my sensor's wet and causing my car to run like crap... i always kept MAF cleaner and a spare filter in my car for rainy days... or wet days... always unhooked the one pipe and let it sit to side and put another filter on (WAI)

GrandAmMe
12-28-2008, 11:52 AM
i kno there was someone around here that had this exact problem. They pulled the MAF and it was full of this moldy looking crap. i say check that first.

Jake
12-28-2008, 12:52 PM
i kno there was someone around here that had this exact problem. They pulled the MAF and it was full of this moldy looking crap. i say check that first.

Ahh so maybe moisture is getting to it from INSIDE the Cai? I will def check that out today.

GrandAmMe
12-29-2008, 08:57 PM
I think this is your problem:
http://grandamgt.com/forum/showthread.php?t=69905&highlight=moisture

unless you havent already found it.

Jake
12-29-2008, 09:16 PM
I think this is your problem:
http://grandamgt.com/forum/showthread.php?t=69905&highlight=moisture

unless you havent already found it.

Nope I havent looked, been soooooo busy, but the car ahs been fine the past day or 2, I am thinking its msot likely the MAF, I will rip into it one day very soon and clean mine thoroughly