Ignition Problem (Friends 02 Monte Carlo) [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Ignition Problem (Friends 02 Monte Carlo)


Jake
01-25-2009, 06:09 PM
I didn't feel like looking through 1234876234 different threads to find this.... so...
Some of you may know, Monte Carlos have the igntion up on the dash like ga's do, so I figure it has to be similar and someone could help me. I know a lot of ga's have the problem with the key not turning, like you have to jiggle it to get it to turn, my old ga still does it and my buddies monte carlo has for a while and finally today the key just flat out wont turn. Anyone know what exactly is the cause of this? Between me him and another 1 of our buddies I think we could fix it if it isnt anything major. If it is, he will just have it fixed at work but I am curious what could cause it and how difficult it is to fix it. Thanks.

Malaclypse
01-25-2009, 07:56 PM
Search for Passlock sensor replacement.

Its the exact same part as the GAs use. Getting to it is a little more difficult on the W-bodies as you have to remove more trim.

The job itself isn't terrible difficult. You do have to re-key the lock cylinder though. And make sure to get a new key cut to the VIN from the dealership. Its the only way to get an accurate cut that fits the vehicle properly.

gagt Mechanic
01-26-2009, 04:38 PM
the issue is caused by the lock cyl, if you need to use it, turning the key while tapping on the back of the key with a screwdriver or hammer. the lock cyl can be replaced seperate from the passlock. call the dealer and give them your vin and they can get you one. you will need to relearn passlock when done.