Low Coolant Light [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Low Coolant Light


The JoKeR
03-23-2009, 12:02 AM
This just started recently and is on a 2004 GT. When I start the car, the low coolant light comes on. After about 2 minutes of driving, the light goes out and sometimes will flicker on and off while I'm driving. I checked the coolant, and it's full. If I add anymore to it, the resevoir will overflow. Is there some sort of sensor that may be bad? I'm also so paranoid about the LIM gasket that I checked to make sure that there was no oil in there, and I just had an oil change and there was no coolant present. Any ideas on what this could be would be great. The car does not overheat and has full fluids.

kse73
03-23-2009, 12:35 AM
Sounds like a bad sensor to me.

FromTheInside
03-23-2009, 07:22 AM
I agree with the bad sensor, when my coolant was low, I got more than just a flicker; it stayed on. Just pull out the plug and check for corrosion and then look into replacing the sensor if you're sure that is the problem. Sometimes you cannot really tell if there is coolant in the oil because it is such a small amount. If you're very worried, pull out the dipstick with the engine hot and place a drop of oil on the exhaust manifold which will be very very hot. If the oil bubbles then there is coolant in there.

The JoKeR
03-23-2009, 11:02 AM
Thanks for the responses! Where is the sensor located? I did the oil on the manifold thing and it didn't bubble so I guess I'm still good? lol The car has 55K miles on it, so the more miles it gets, the more I get worried lol