steering not totally centering [Archive] - GrandAmGT.com Forum

PDA

View Full Version : steering not totally centering


ga2001gt532
03-26-2009, 07:42 PM
alright my car has 170000 miles on it the only problem is one of my bearing sensors are acting up, but when i go to get on the highway by my house, you have to turn pretty sharp to get on but once am going stright the car wants to pull that way. it will also do this if i turn the other way sharp. i want to fix this but i don't want to be replacing parts that wont fix it.

GrandAmMe
03-26-2009, 07:45 PM
Sounds like an alignment issue to me but i could be wrong....

ga2001gt532
03-26-2009, 07:48 PM
yeah the steering wheel is alittle off but i think that is because i have to counter act for it pulling one way or the other, but it mainly pulls to the left. i just dont want to get it aligned for it to still have the problem thats why i'm asking before i get it aligned.

PhantomLover007
03-26-2009, 09:19 PM
I had been noticing the same thing before and when I took it in to get checked out and aligned, the tech said that it didn't need an alignment. It seems worse on the roads w/ the crowning. The tech told me it was .. somethng torque. I can't remember exactly what he called it.

Lab Rat
03-27-2009, 06:41 AM
I found my camber was off quite a bit. That will make it pull. 2nd problem was rotted out strut mounts. They tended to stick rather than turning (and returning) smoothly. The alignment shop may tell you the camber can't be adjusted. Slotted strut holes or a camber kit will both allow that adjustment.

ga2001gt532
03-27-2009, 03:44 PM
so basicaly i think i need new struts in the front so could that be my problem or is it more in the steering

tenspeed
03-27-2009, 07:15 PM
Squirt some oil in the openings at the top of the strut mount. It lubes the rubber ashtray looking thing and the car won't pull any more. I have to oil mine about once a year.

ga2001gt532
03-30-2009, 03:59 PM
i've oiled the struts and that didn't help any.

tenspeed
03-30-2009, 06:15 PM
i've oiled the struts and that didn't help any.

Check out this thread - it goes into detail.
http://www.gaownersclub.com/forum/showthread.php?t=80384

ga2001gt532
03-30-2009, 10:06 PM
yeah i know what your talking about i tried oiling mine twice with no affect, plus mine don't make popping noises like everybody elses. maybe if i used the screwdriver like you did it would help more because my oil just sits their in that bowl. but i don't think thats my problem.

tenspeed
03-30-2009, 10:33 PM
but i don't think thats my problem.

I'm thinking that it might not be your problem too. My car was doing the same thing and oil fixed it. Too bad it didn't work on your car.