light hesitation [Archive] - GrandAmGT.com Forum

PDA

View Full Version : light hesitation


Badblack04GT
04-24-2009, 07:14 PM
Got a light hesitation in my '04 GT. When I'm very light on the throttle it kinda jerks a little. Plugs and wires have 20K, no trouble codes. I've cleaned the MAF, checked the TPS and checked the MAP.


I'm not used to OBD2 stuff, if it was OBD1 i'd just datalog it but i lack the equipment for OBD2. :(


Thanks for any ideas.

Dave

FromTheInside
04-26-2009, 07:08 AM
Check all of your coils and verify all of your plugs and wires are fine. Also, a bad injector or low fuel pressure can cause this. Maybe clogged filter or fuel pump being stupid. Check your fuel pressure regulator for leaks.

OneFstGt
04-26-2009, 07:21 AM
I had a light hesitation when on the throttle and it ended up being the IAT sensor Harness right were it plugged in.

Badblack04GT
04-28-2009, 10:02 PM
Thanks.

FPR isn't leaking, haven't checked the pressure yet though. I'll check that and since i've got a spare MAF i'll go ahead and toss that in.

ITSmyGT
04-29-2009, 10:58 AM
I would more than likley say a fuel problem, my wires for my MAF broke but no hesitation only thing I had was a SES light, try injector cleaner on your next fuel up then run it around for the next couple of days.

Badblack04GT
05-02-2009, 04:53 PM
Turned out to be the plugs, i forgot that it had Autolite Platinums in it. They didn't look too bad for 20K but a set of spare Iridiums from my 3500 build took care of it. It runs like a top again. :)

Thanks for the suggestions.