Intermittent electrical [Archive] - Forum


View Full Version : Intermittent electrical

05-26-2009, 11:34 PM
So tonight my wonderous car decided to throw yet another hiccup my way. when starting the car tonight, it chimed once and went dead, no cabin lights, chimes, nothing. Brand new battery, so I checked the connections and they seem tight, went to grab a flashlight out of the dash and noticed the cabin lights were back on, turned 'er over and she ran like snot... until about 1km down the road where I turned on my highbeams and all electrical went dead for about a second, came back on. The rest of the ride home I'd occassionally lose my stereo (again for a second) but the lights stayed on and the car didn't lurch like the first stall out, windows work without issue. If i was stuck at a stoplight for too long the headlights would dim/pulse. Also, my ABS light is on all of a sudden.

I guess i'm wondering if this coudl be a fuse issue, or a holdover from my starter burning up the fusable link? The connections on the battery should still be clean but I'll check that tomorrow, the battery's less than a month old. Also, my speedo seemed to be.. floating.. only way to really describe it, bounced and jiggled between 110 & 130 most of the way home..

05-26-2009, 11:54 PM
sounds like bad connections

05-27-2009, 12:04 AM
as long as it' sjust the battery connections, i'd rather not spend all day tomorrow following cables :O/

05-27-2009, 11:21 AM
Sounds like you have the red cable rot going on.
Pull back the rubber and see if its rusted.

If not check the grounds on the engine and frame, Might have rotted out on the frame and just not grounding right.

05-27-2009, 11:43 AM
Sounds like a great time for a big three upgrade

05-27-2009, 11:58 AM
big three upgrade?

05-27-2009, 12:13 PM

05-27-2009, 12:24 PM
ah thanks for the link, looks like a good afternoon project