A/C compressor ping sounds [Archive] - GrandAmGT.com Forum

PDA

View Full Version : A/C compressor ping sounds


99blackgagt
06-01-2009, 10:21 AM
when i am driving and turn on my a/c , the pump will start making a constant ping or knock sound and i can make it go away by turning the a/c off....also when sitting in park and turn on a/c it makes the same sound (same sound everytime a/c is turned on whether driving or sitting) could it be a bad compressor? or does it need more FREON or whatever the stuff is?

juanvan
06-01-2009, 11:58 AM
Sounds like the pump might be bad - How was the system last time you used it?
Cold - not cold but cool - warm?
It sounds like the oil in the compressor might have leaked out.

99blackgagt
06-01-2009, 10:30 PM
the air coming out of the vents is still pretty cold like it was normally, but as soon as i hit the a/c button the knocking begins and when i turn it off it stops...i think the pump is bad but i just had it replaced like a yr and a half ago?

juanvan
06-02-2009, 06:03 AM
Have you looked at the ac pump when it is engaging under the hood? To see what the clutch is doing.

This is the worse case -
Sounds like someone did not put the oil in the pump prior to installing it.
It worked fine for a year b/c there was manufacture oil in the pump - when they ship it it has a coating of oil. When you get the pump you are suppose to put X oz's of oil into them.

Then hook it up and put the R coolant in and start the pump. I would assume that you did not use the AC for the past few months being in a northern state during winter. The pump never engaged over that time and the parts sat after being used with out oil.

The best case is maybe the clutch went bad..