Over heating... [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Over heating...


Doobydoo
06-29-2009, 10:32 PM
Okay so my 2000 Grand Am Gt is over heating...I checked the water...at first i thought i had a leak because i would have to feel the water over again....i checked for that...there are none...after that i checked the thermostat and its not getting any water to engine...i replaced the thermostat with a brand new one...still over heating..please help immidiatly

westerndragon
06-30-2009, 04:11 AM
what do you call over heating

it's common for GA's to run about 220

i replaced the stock thermo with a 180* one and i still run just a touch under 200

Doobydoo
06-30-2009, 07:05 AM
like over heating is as 240....constantly.

AaronGTR
06-30-2009, 08:39 AM
Bad water pump or plugged radiator maybe. You really have to make sure there is no coolant moving through the radiator hoses though before you settle on that as the problem, because it could also be a blown head gasket.

Doobydoo
07-04-2009, 09:34 AM
well what i;ve done so far is...replaced the thermostat...still not working....replace the water pump still not working....i have no water flow to the engine....i haven't found any leaks yet so...i dont know the problem

BOOTMASTER
07-05-2009, 11:18 AM
check/replace your overflow fill cap, mine was bad and caused overheating and water loss....

you could have an air bubble in the system, i had the same problem... but if i let it get warm and revved it up it would be ok for awhile... also, if your filling it up, make sure its on a cold motor

X2 on possible intake manifold/head gasket failure

Doobydoo
07-05-2009, 12:07 PM
ive got flow through the radiator... i have not tried the overflow fill cap...thanks i will try that here soon and get back with you

where can i get one of these

Doobydoo
07-07-2009, 04:32 PM
bump...still need help