Fog light problem [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Fog light problem


DarkKnightZX
07-13-2009, 11:02 PM
Hello everyone new guy here with a quick Q. My fog lights wont work on my 04 GAGT I have checked the fuse, relay and bulbs all r good. Any ideas?

PhantomLover007
07-14-2009, 10:52 PM
Daytime or night time?

burgett2103
07-14-2009, 11:04 PM
could be a short throughout the harness.. if you took it off to paint the fog light thing, then maybe you didn't connect it back all the way

lone_wolf025
07-14-2009, 11:52 PM
If your headlights are clicked to the on position and the car is running and brights are off they should get power. If you have a volt meter you can check it. With my car I need new plugs cuz the current ones don't seem to work right. If I push the wires in the back of the plug in further the lights will go on. But if I take the pressure off they go off.

Haughee
07-15-2009, 08:22 AM
Does the relay click when you flip the switch with the headlights on? Mine went bad and the relay was causing mine not to work.

DarkKnightZX
07-15-2009, 05:02 PM
Havent taken anything apart to paint it. Yeah it clicks but the LED on the switch doesnt light up. bad switch?

lone_wolf025
07-15-2009, 06:22 PM
If the switch was bad the relay wouldn't click. How did you check the relay? Did you replace it with a known good relay?

DarkKnightZX
07-15-2009, 08:03 PM
Yeah I did. A dealer around here said the last owner could of put a different BCM in it not programed for fog lights. Possible?

DarkKnightZX
07-18-2009, 04:49 PM
Bump

lone_wolf025
07-18-2009, 05:31 PM
Yeah I did. A dealer around here said the last owner could of put a different BCM in it not programed for fog lights. Possible?

Thats a bit out there but its possible. Pull the relay out and check to see if the hi-power side is sending power down the circuit. If you're getting current from the hi side of relay the BCM isn't the issue and you've got a short in the line somewhere or a bad ground. If thats the case you'll have to check the wiring from the relay back.

blazingerbs
07-19-2009, 03:47 PM
it's the relay
mine would click but the contacts inside are dirty and the lights and led wont turn on.
just took apart and cleaned with contact cleaner, worked ever since (6 months)

lone_wolf025
07-19-2009, 04:17 PM
it's the relay
mine would click but the contacts inside are dirty and the lights and led wont turn on.
just took apart and cleaned with contact cleaner, worked ever since (6 months)

That's what I would've thought, but he said he swapped the relay with a known good one. Plus if it was the relay personally I'd spend the $2 to buy a new one.

DarkKnightZX
07-19-2009, 04:49 PM
Yeah I put the trunk release relay in it since its the same. LOL they want $12 for one here! will try and take things apart for a closer look in the next few days.

lone_wolf025
07-19-2009, 05:06 PM
Yeah I put the trunk release relay in it since its the same. LOL they want $12 for one here! will try and take things apart for a closer look in the next few days.

$12?? For a dinky little relay? I take back my previous statement...

DarkKnightZX
07-19-2009, 09:00 PM
Yeah no joke! of course thats from a dealer. didnt bother looking anywhere else yet.

lone_wolf025
07-19-2009, 09:10 PM
Yeah no joke! of course thats from a dealer. didnt bother looking anywhere else yet.

A relay you can get at just about any parts store. I'd swing by one of the chain stores or a local dealer with the old relay in hand and see what they say if I needed one.