Car acting a bit funny [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Car acting a bit funny


Jake
08-04-2009, 07:41 PM
Has only done this twice, same spot, right before I get on the highway to go to work, car is about 1/2 way up to operating temperature. I turn a corner, and it is smooth through first, and second gear, and right before it's about to go to third gear, the car sputtered for half a second like it wasn't getting any gas and then I gave it more gas, and it went along fine the rest of the way to work. Has only done it twice, and at pretty much the same MPH and RPM as before, also at this time, my A/F gauge reads all the way lean.

The other thing is, when I am on the highway, if I gas it and the car is at like 3k+ RPM's for like 5 seconds or more, when I let off the gas, the rpm's drop, and the car kinda sounds like it wants to die, but doesn't sputter or anything, (I can just hear it in the exhaust tone) and my A/F gauge reads so far lean that the light disappears and when I give it gas, the car comes back and sounds normal and the gauge reads normal again. ONLY does this when I gas it, and suddenly let off.

Halp please.

Now I know my front 02 sensor is kinda jacked (throws a p0132 code for high voltage whenever it feels like it). But can a bad 02 sensor affect something like this or will it just screw with my mileage and throw codes?

lone_wolf025
08-04-2009, 08:47 PM
Your O2 sensor could arguably be a culprit because if it reads rich even when its lean the comp will try to lean it out even more. Your problem sounds similar to how I've noticed a gradual drop in power with consistent throttle pressure that immediately goes away and returns power with a harder tap of the gas. Unfortunately I don't have an answer :(

The highway part at 3k rpm doesn't sound TOO strange as injectors will typically go to practically nothing with no gas pedal on highway cruising, but I've never driven highway with an eye on A/F ratios.

Jake
08-04-2009, 08:57 PM
Your O2 sensor could arguably be a culprit because if it reads rich even when its lean the comp will try to lean it out even more. Your problem sounds similar to how I've noticed a gradual drop in power with consistent throttle pressure that immediately goes away and returns power with a harder tap of the gas. Unfortunately I don't have an answer :(

The highway part at 3k rpm doesn't sound TOO strange as injectors will typically go to practically nothing with no gas pedal on highway cruising, but I've never driven highway with an eye on A/F ratios.

I figured the highway part might be normal but I wasn't sure.

I just need to replace that ****in 02 sensor lol.

PhantomLover007
08-04-2009, 09:14 PM
She knows your trying to get rid of her Jake... lol

Jake
08-04-2009, 09:16 PM
She knows your trying to get rid of her Jake... lol

Yea I am getting to the point of maintenance ****... Have never done anything to the car besides front brakes since I bought it over 2 years ago.

Recently did trans flush, coolant flush, power steering flush, new serpentine belt, new radiator hoses.

lone_wolf025
08-04-2009, 10:56 PM
I figured the highway part might be normal but I wasn't sure.

I just need to replace that ****in 02 sensor lol.

Well if that fixes your P0132 issue lemme know lol

GrandAmMe
08-04-2009, 11:11 PM
Yea I am getting to the point of maintenance ****... Have never done anything to the car besides front brakes since I bought it over 2 years ago.

Recently did trans flush, coolant flush, power steering flush, new serpentine belt, new radiator hoses.

I would like to see the state of your cars oil. lol

Jake
08-04-2009, 11:25 PM
I would like to see the state of your cars oil. lol

Besides oil changes :p

PhantomLover007
08-04-2009, 11:30 PM
I would like to see the state of your cars oil. lol

I bet it's not like my mom's Nitro w/ no oil change in the last 15,000+ miles... ;crap

Jake
08-04-2009, 11:35 PM
I bet it's not like my mom's Nitro w/ no oil change in the last 15,000+ miles... ;crap

My old boss bought a brand new honda minivan and I remember being in it one day and it said change oil in -999 miles and i'm like uhhh you should probably take care of that, she goes yea it has said -999 for like a month.

iceman
08-04-2009, 11:50 PM
Clogged injector?