ABS light/SVS/ ebcm [Archive] - GrandAmGT.com Forum

PDA

View Full Version : ABS light/SVS/ ebcm


white04
09-03-2009, 12:05 AM
OK.....So I had my brakes fixed the other day. And my ABS light was on, when I picked up my car the guy had told me that my EBCM was bad. My ABS light was on by its self for about a month.....then the other day my SVS light also came on with the ABS light. Well he fixed my brakes, and they went off...now there back on. So I have read all the post on hear about some thing in the hub are some sensors beeing the prob. but nothing on the EBCM (well not much) So my question is, how many or has anyone had this part replaced and that actually be the prob. And also how much does an EBCM cost? Well any help would be appreciated thanks.
By the way this is on my 99 GA GT

04GrandAM SC/T
09-03-2009, 07:53 AM
If I remember correctly One of your wheel speed sensors is bad or dirty. And the only way to fix it is by replacing the Hub and Wheel bearing assembly. This is because the sensors are built into the assembly. Can cost an upwards of about $100 a pop. Someone correct me if I'm wrong. I know this happened to my 04 GAGT.

2000 GT Coupe
09-03-2009, 01:23 PM
I would agree with 04GrandAm. You will need to have the ECBM scanned to find which hub is the problem. The ECBM is less likely to go bad then the hub.
I thought I had a dead ECBM when I got my car I got one from a "Auto Recycling" place for $30 it did not fix the problem I got a couple more before I found a bad ground and fixed the problem.
If the unlikely chance your ECBM is bad I have one I would sell for $30 plus shipping.