Frustrating whistle at cold start! Fuel pump/filter? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Frustrating whistle at cold start! Fuel pump/filter?


JfBrshie56
09-21-2009, 03:56 PM
Alright, I've done a bit of searching and can't find anything that sounds like my noise. It is only perceptible at cold starts, and particularly for the first minute or two of driving. I've recently replaced several vacuum system components, including the purge valve, pcv valve tube, and fuel filler neck. Filler neck solved the dreaded P0442.

Anyway, the whistle seems loudest while sitting in the car, and any time I've tried to get out and check where it comes from, it seems to vanish. It almost sounds like the whistle is from some sort of fluid flow. The whistle gets louder with a slight pitch change as I throttle up to maybe . . . 2k . . . then disappears. Is it possible that it could be the fuel pump or filter? Fuel filter has around 20k miles on it.

Throttle body was replaced around 80,000 miles, but is stock size. No CAI or gatorback belt (Gatorback is going in this week, though).

Any ideas?

ChosenZero
09-21-2009, 04:00 PM
It might be that the belt is loose, does it happen mainly on a cold start? If you messed with any of the pulleys lightly, you may want to re-tighten it, and if not, I say do it anyways, and may as well change the belt, but that's how I got mine to stop.

Pauljp
07-03-2010, 01:52 PM
I just installed a CAI and I immediately noticed a whistle while sitting in the car.
My wife, standing beside the car says she can't hear it.
It is more noticeable between 2k-3k rpms, and seems to disappear when the engine gets warm.
I love the throaty sound when you kick it down, but not too crazy about the whistle.
Anyone else notice this?

westerndragon
07-03-2010, 03:20 PM
you probably have a loose fit would be my guess the whistle is making the intake leak act like a reed tighten the screws on your airbox and cai clamps respectivly

PhantomLover007
07-04-2010, 12:56 AM
Whistle tips?

Mike Jung
07-04-2010, 01:26 AM
Emissions Air Pump ?

Pauljp
07-04-2010, 08:52 AM
you probably have a loose fit would be my guess the whistle is making the intake leak act like a reed tighten the screws on your airbox and cai clamps respectivly

I think I'm going to go with what Westerndragon says.
It's got to be CAI related as that is the only thing that I changed when the whistle started.
I'm going to go out and tighten all the clamps.
I did notice while installing, that my throttle body is oval shaped and the pipe that my vent tube and IAT sensor goes into is round, and the coupler that connects the two is only 3" wide.
Perhaps the oval shaped TB is where the problem lies.
I always thought TB's were round... Funny.
I also only used a screw driver to tighten the clamps, now I will use a ratchet and socket for more torque.
I will post back today with the results.

Pauljp
07-04-2010, 02:45 PM
Well I verified the clamps with a ratchet and all is tight.
I could not verify the clamp around the cone filter as it is in the fender and I would have had to remove the tire and splash guard to get at it.
Next week-end I will verify the filter.
It is an S&B cone filter that came with the CAI package from MPRacing.
Is this a good filter or should I exchange it for a K&B, or is it all the same?
Has anyone noticed a whistle with an S&B filter?

Mike Jung
07-04-2010, 06:54 PM
...It is an S&B cone filter that came with the CAI package from MPRacing.
Is this a good filter or should I exchange it for a K&B, or is it all the same?...
KEEP the S&B Filter !!!

Don't buy into the marketing of K&N.
S&B Filters are better.