Warning Lights on (ABS, TRAC, SVS) [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Warning Lights on (ABS, TRAC, SVS)


jetpackjeff
09-26-2009, 08:09 PM
At random times while I am driving the ABS, TRAC OFF, as well as the service vehicle soon lights come on and I have noticed that my traction control does not seem to be working correctly but the car feels normal to drive otherwise. It comes on usually after driving for about 10-20 mins and before that my traction and ABS works fine.

Anyone know if this is a common problem? the TRAC button does not work when the three lights are on either. I hope this is not a big problem, I am a starving student!!

2003 Grand Am GT1 with Warm air Intake.

Sorry for the desperate post by a noobie I have not had the car for very long but have been browsing the forms for quite some time. If anyone can give me some advice before I have to bring it in for servicing that would be great. I have never had a problem with the car before and it runs beautifully. Had the brake rotors and pads replaced about 3 months ago as well as all new tires when I purchased the car used.

Thanks in advance guys! any tips would be much appreciated

skifreak122
09-26-2009, 09:11 PM
The first thing I'd check is your front wheel speed sensors. On the backside of your wheels you'll see wires connecting into the back of the hub assembly. Make sure the wires are still intact/good condition. Unplug the wires at the connection and give them a good spray with some wd-40 or similar product then re-connect. Repeat on other side.

Generally, a simple cleaning of the connections will solve the problem you've described.

Tip: It's a bit more time consuming, but taking off the wheels to do this will make the job much easier.